Error in uploading forms to the KoBoToolbox server from the KoBoCollect android app


I am using KoBo toolbox since last year. Recently one of my data collector faced issues while sending finalized forms due to poor network connectivity.

Since then he is not able to send those failed forms.
Both (not sent and failed) form appear in his finalized forms but it gives error while sending- XML file does not exist (attached screenshot).

Any suggestions?

Error massage after trying to send


Hi @amolkulavmode
Thank you for reaching out on the forum with this issue. If I get your issue right:

  1. The forms that the user is trying to send were filled in last year.
  2. This only affects one of the users.

I would like to help you troubleshoot, so kindly confirm the following:
1. Deployment related issues
a. Did you deploy a new version of this form after last year?
b. Did other users manage to submit during the same period of time as this user?

2. Potential deletion of forms
a. Can the user access the forms within the specific folders i.e. if they follow the specific file/folder structure can they see the XML files in them? Note this is using a file explorer.
b. Did the user ever delete the files on their phone, albeit accidentally?

2. KoBoCollect update
a. What version of KoBoCollect was used to collect the data?
b. Did the user update their KooCollect or rather, what is the version of KoBoCollect on the user’s phone?
*Hint: The current update of the KoBoCollect has particular requirements that change the handling of the folders used by the application. This may, in essence, affect the way the form reads previously collected data that had not been submitted.

Once you provide this additional information, we can be able to best assist you.


1 Like

Thanks Stephan for your suggestions.
I haven’t deployed new version. Data is ongoing and only single user has faced this issues. He collected data 4-5 days before and tried to send. After 1st failure (due to network issues), next day he tried again and since then above error massage is appearing while. Also he can see XML files in his folder (attached screenshot) but not able upload.
I haven’t checked other possibilities. I will follow other suggestion as well.


Hi @amolkulavmode,

Would you try as outlined below (it should help solve your issue):

  • Go to the Edit Saved Form
  • Select the form and then open it. Check if there are some mandatory questions un-filled. If it’s OK, SAVE the changes.
  • Then try sending the filled up form to the KoBoToolbox server.

Kindly please let us know if it worked.

Have a great day!

1 Like

Thanks for suggestion.
Will try and let you know.