Error message seen when trying to edit a submission

Hello guys!

I am facing a similar issue while trying to edit some data already submitted (see message of error below)


I have been trying for a while to understand why certain forms can be edited while others have problems such as this one, and I would really appreciate your help to identify where the problem is… Is that related to skip logic somehow?
I checked the code for q40 (mentioned in the error message) but everything seems fine (see screenshot below)


@gbompani, do you get any error message when trying to fill a blank new survey form too?

No, only when I try to edit an existing submitted form

OK, would you mind trying to validate your xlsform with this online validator and see if it has any syntax issues?

Only the usual stuff: it says it doesn’t recognise kobomatrix type of questions and it flags that there are groups without labels - nothing seemingly related.

OK, so as a check, could you remove the kobomatrix and then see if it can capture any other issues?

Only the missing label for certain groups, as well as another yellow error message I didn’t notice before about the language:

The following language declarations do not contain valid machine-readable codes: english. Learn more:

@gbompani, maybe a screenshot of the same would be much helpful.

OK, could you also show us the top part of the online validator?

part1 part 2 part 3

Still above.

There is nothing above, only the instructions. Check it out!

1 Like

OK. Seems like everything is OK with the xlsform. As a final check would you mind doing the following:

  • Upload this xlsform as a separate dummy project
  • Make some dummy entries
  • Check them by editing the submissions from your KoBoToolbox server

Hi dear,
this is actually a dummy project/dummy entries. Basically i entered a dummy entry and tried to change it right after, and it was impossible.

@gbompani, just wanted to ensure that we could replicate the same issue with the other project as well (when we have the same xlsform used).

Nope. I tried with two more forms and it’s not working. I suspect the problem is somehow linked to part of the form where we have repeat group, but i cannot pin where or why

OK, could you share your xlsform with the community? Maybe the community could help you solve your issue?

Hi @gbompani
Could you try to filter in excel for all the repeat questions and run your assessment first before you send the XLS form? As it is this is a case of a minor omission on your end which you should be able to easily solve by inspecting your XLS form.


1 Like

Hi @stephanealoo, thank you (and as always @Kal_Lam ) for your help.
I also think there must be a problem with the repeated groups, but I still can’t identify it. Due to the shape of the data we have to collect, we introduced several repeated groups, within an overarching group that can also be repeated. Do you think this is the source of the problem?

You can see a screenshot of the filtered code below.