Error message Start tag expected, '<' not found when editing submissions

Dear community
The issue I posted on Jun 23th has not beeg solved yet,
Please can someone help me to solve it?
Thanks in advance

Kind Regards

Thank you for your patience @corylus2020! We will get back to you soon.

Hi @corylus2020, I apologize for only looking into this now! Please note that the issue has now been resolved and you can continue editing your submissions :slightly_smiling_face:

1 Like

Thanks a lot Josh!!!

Kind Regards


1 Like

Hi Josh
Sorry to disturb you , but today I’ve got again the same error message so that I can’t edit any submission

Thanks in advance for review one more time the issue

Good Monirng
I’ve got again the same error message I got in July (finally solved by Josh)

Please , could you check and solve it again? Is there any way to avoid it to happen again?

Thanks in advance

@corylus2020, I have merged this topic back to the original topic. Could you share a screenshot of the issue you are getting?

Hi Kal_Lam
Please find below the screenshot of the error

As you can see it`s the same I’ve got in Jun


@corylus2020, is it the same project?

Yes, it´s the same project

Thanks for you support!!

Hi @corylus2020, please note that the issue is now resolved. The problem is revealed if you attempt to preview the form and gives this error:

If I then download your form as an XLSForm and reupload it then the issue resolves itself. Are you developing your form using XLSForm or the formbuilder?

1 Like

Hi @Josh,
any idea what can cause such KoBo problem - which is solved by just downloading and uploading the latest same version?

Maybe the latest form version was used on server level but not yet deployed? Which form version does KoBo use on modal edit and view on server level? The last deployed one?

Kind regards.

@wroos this has actually been a mystery to me until solving this issue today: Export Failed Error message while downloading data from KoBoToolbox server - #24 by babajide_oluseyi

If I replicate the issue on that thread, trying to edit submissions reproduces the issue on this thread about the “Start tag…”. Hopefully resolving formpack#303 will fix both cases.

There was additionally an issue here that caused this: Changes in pyxform behavior break submission editing · Issue #3751 · kobotoolbox/kpi · GitHub


Thanks @Josh,

Even if there is a newer not yet deployed one?

Hello @Josh,
To dig deeper, we might review again similar cases you treated here before, e.g. Search results for 'Start tag expected, '<' not found' - KoboToolbox Community Forum
All since March, mostly June this year… Modal edit, preview …
So, all cases popped up after March release?
Release Notes - version 2.022.08, 2.022.08a
(I couldn’t find a similar error before or in the ODK forum.)

For me, it seems related to #3751… Your “solutiion” with download/upload indicates that some difference against direcly editing makes the turn.

Sorry, from a user regard, it is confusing and a bit strange that different (parsing/converting) tools are working in the background and create such problems, esp. after an update.

Thanks @wroos for adding some additional context. We are investigating and will keep an eye on this particular issue coming up occasionally.


Hi Josh

I did some small changes using the formbuilder

Thanks a lot for the support!!

1 Like

@corylus2020, has the issue been solved or is it still on?

The issue is already solved. Thanks!!!

1 Like

Thank you for confirming, @corylus2020! :clap: :heart: :partying_face: