Error message while trying to import the data collected

Hi all,

Following the data collection, we are receiving an error message while trying to transfer the form from the smartphone to kobo online platform. We tried to connect the phones with a cable to the computer but its not working and we tried also this s method: Transferring forms and data manually from one android device to another — KoboToolbox documentation. The error message is attached and mentioned a generic error. Do you have any advice/solution?

Thanks in advance,

Welcome to the community, @si_juba_meal_co! Maybe this post discussed previously should help you solve your issue:

By the way, I would advise you to submit your data to the server through the online app. This should be more straightforward.

Feel free to reach us back if you should still face the issue.

Thanks for your feedback. We tried and it is still not working for all the phones that we have. The number of submissions does not change before and after the synchronization process.
For the app, we use the normal KoBoCollect app on the phone but it is not working.

Thanks a lot for your support.

I tried to do it manually by importing form in bulk and the error message is

I have also one message mentioning “Error: connection closed by peer”

@si_juba_meal_co, is this an issue only from a single device or is this an issue from multiple device?

We face the same issue for 6 devices connected to 1 survey

@si_juba_meal_co, would you mind validate your XLSForm through this online validator to see if there are any syntax issues?


Thanks for your feedbacks. We already collected data and no problems have been identified during the initial form downloading and data collection process. Ive checked the form in the tool and it seems to be fine. We are struggling to transfer the forms that have been completed to the online Kobo software.

Have a nice day,

@si_juba_meal_co, maybe you will also need to check if the project is still deployed in your account? It could be an issue if the project is not deployed in your project. Please also note that the latter deployed projects should not be able to hold your data that you manually try to upload to the server. It will require the original deployed project.

Hello thanks for your swift feedbacks! According to the attached picture, the project is still deployed. Can you confirm that it seems fine?

This seems fine @si_juba_meal_co! As a cross-check, could you check the data entry link generated from this project to tally with the URL link that has the submission issue? If the URL is the same, it’s the same project deployed. If the URL is different, then it’s another project. It should be an issue if the projects are different.

Could you let me know how to check the data entry link and the URL link? As for now, I can just identify the URL link in the server settings tab of the phone application. Ive checked and this link is the correct one but its not connected to the form (but to the account)

This is the new error message that I received

@si_juba_meal_co, 404 error or ‘page not found’ error is a Hypertext Transfer Protocol standard response code that indicates the server was unable to find what was requested . This message may also appear when the server is not willing to disclose the requested information or when the content has been deleted.

Maybe you will need to see if this project is still there on the server (for the data you are trying to submit)?

Hi, can you share what is the error you faced when you trying to send the specific message, so then will be able to share my views on it.

Hi, thanks a lot for your follow up - I finally enter all the data manually as I was running out of time. Thanks both for your support and have a nice day

1 Like

Thank you for confirming @si_juba_meal_co!