Export Failed while downloading data from KoBoToolbox server

Noted. Thanks for the support

1 Like

@nyxz86, @reach.arm, kindly please be informed that the issue has been solved, and you should be able to download your data normally.

Hello. Sorry to get into this topic that is solved. I am facing the same issue. Two days ago we could not download the data with tags but only in legacy XLS version. Our server is: kc.kobotoolbox.org

Faced with the two questions you ask in the previous comment: Yes, we have recently modified the form and it contains group questions but not from another form.

Welcome to the community, @comunicacidemos! Could you also share us a screenshot of the issue so that the community should also be able to understand your issue pictorially? In addition, could you also provide more details on what modifications did you make that caused this issue? These details should be helpful for us to see if it’s already a known bug that has been resolved and is in our pipeline for the next release (which is happening very soon).

Thanks for the welcoming @Kal_Lam! Here it is:

We’ve made modifications related to labels and choices but these changes have been made before without issues. Btw, we recently modified the language.

1 Like

@comunicacidemos, would you mind downloading the data in XLS (legacy) format to see if you can download them? Please let us know what happens.

Of course @Kal_Lam. We downloaded the data in XLS legacy format without problem. However, we would like to have the option to download this data with ‘labels’ to facilitate internal reports with this form.

*Currently we have other forms working correctly for downloads with labels.

Thank you, @comunicacidemos, for updating this post. It could be a bug that has already been fixed, which will be live tentatively next week. Could we wait till then? Maybe you could use the XLS (legacy) till then. I will update the post once we have the release live. We could then see if the bug fixed should address your issue. If not, maybe we could create a new issue for your case.

Thank you, @Kal_Lam for the support.

Starting this week we were trying to download the data but the bug continues. Instead, we are downloading XLS (legacy). We would appreciate all the support in case it is possible to solve it.

1 Like

@comunicacidemos, would you mind checking if the recent release has fixed your issue?

If not, maybe we will need to further explore your issue to identify the bug. Please feel free to reach us back.

Thank you @Kal_Lam for this information, however, the bug continues in this particular form. We would be grateful if there’s any option to fix it. We continue to download from XLS(legacy). Other forms work properly.

1 Like

@comunicacidemos, would you mind sharing the following details through a private message? I would like to have a closer look at your case.

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

Hi @comunicacidemos, I have created an issue here that you can track for this. In the meantime, you continue either exporting using the legacy exports option or by unchecking the box “Include data from all 23 versions”:
Screen Shot 2022-03-23 at 9.56.49 AM

1 Like

Hi @Josh, Now we are downloading the data on latest version of this form properly and we’ll follow the issue you have created for all other versions. Thanks for the support.


Hi Kal_Lam,
I am facing the same challenge. I redeployed the form yesterday adding 2 new module and topic of the raining, entered the data and now as I download new data the update doesn’t show anymore, it seems I have lost some data. I usually export data and put them in excel sheets that are connected with power queries, and something is wrong with those querries. Will you be able to help me? Please

@DilZok, would you mind downloading your data in XLS (Legacy) format to see if the data are there?

How do I do that? is there are web site for checking?

@DilZok, you could download your data in XLS (Legacy) format as shown in the image below:

This is what message I am getting. I can download the data in xls, I see row data is there, because new data has been entered countiniousely, because we are having data collection at the moment. But when I put them in other excel sheets that are connected to PowerBI and have connections and queries, this is when I face a problem. Excel keeps showing an error message as: Evaluation ran out of memory and can’t continue. This is where I am lost and can’t find answers. Can I share my files and someone from the community see the queries? I did not set the queries, our previous data scientist did. I do not understand anything, but I am responsible for not losing and showing them in the PowerBI for the staff.


вс, 3 апр. 2022 г. в 13:12, Kal_Lam via KoBoToolbox Community Forum <noreply@community.kobotoolbox.org>:

@DilZok, did you press the New Export to get the data in XLS (Legacy) format?