Failure to get new form on tablet after updating the survey in Kobo ToolBox

Trying to Get New Form on my Android tablet after I updated the survey in Kobo ToolBox but it keeps failing. Any help to get this solved?

Welcome to the community, @rgitangaza! Have you gone through our support article Collecting Data with KoBoCollect on Android? It should help you solve your issue.

Feel free to reach us back if the issue still persists.

1 Like

Hi @Kal_Lam,

Thanks your quick response. I have read the articles. To make clear enough, I started creating the form in December and I could deploy it and access it on tablets. I updated the form in Kobo ToolBox yesterday and redeployed, but when I try to get the form on the tablet, it keeps failing. This in new!!

Could you try it on another device and confirm if this is still the case.

1 Like

Hi @stephanealoo,

I tried different devices, but still doesn’t work.

Can you share your username and a screenshot of the setup you have on the collect. Kindly also indicate the name of the project. Use a private message for this

1 Like

@Stephanealoo, I am having a hard time sending you a private message. COuld you please send me one or direct me how to. Thanks!

1 Like

Often using the SEARCH function of the forum can bring (quick) help, e.g.

1 Like

@rgitangaza, could you kindly share with us the screenshot from General Settings>Server from your Collect android app? This should help us troubleshoot your issue.

Hi @Kal_Lam,

Please see the settings image below.

@rgitangaza, is the username and the password entered correctly?

Yes, they are both correct.

Well, you could also try this approach then:

Your username should be gotit. Keep the other settings as it is currently.

I just tried it as well, but the issue persists. I added the username (gotit) to the URL.

Could you ensure that the device has an internet connection?

It is connected.

OK, as a final check could you uninstall your Collect android app and then reinstall them in your device again? Let’s see if this works out?

I reinstalled the app See the image 1

. Something else that I tried is: I cloned the survey and tried to get the new survey (cloned), but it keeps failing as well.

One final try. Would you mind getting the blank form to one of the other devices that you have and see if you are able to pull it there?

Surprisingly, it is a success on a device that I had never used for this project.