Forwarding upon submission does not work

I am attempting to trigger an API call after a survey submission. However, it looks like the ‘Forwarding upon submission’ does not work at all.

Ideally, this survey should forward to google after submission but it does not:

https://ee.kobotoolbox.org/single/i8W4X310?returnURL=https://www.google.com

Instead, the flow stops here and does not continue to the redirected URL

Is this a deprecated feature or am I doing something wrong?

Welcome to the community @dankaranja! Maybe this post discussed previously should help you solve your issue:

Note: It only works with Online-Only (single submission).

Hi @Kal_Lam

Thanks for getting back to me.

This is what I believed as well. However, configuring the survey to ‘Online-Only’ under ‘Collect Data’ doesn’t seem to persist, infact, it doesn’t seem to save that configuration at all.

After setting it to ‘Online-Only’ and navigating away from the Form page and back again the setting always reverts back to Ónline-Offline’(multiple submissions). I have also tried to redeploy, but still no luck.

What am I missing?

After checking the Collect data to 'Online-Only (single submission)you will have to pressCOPYorOPEN. If you press COPYyou should get the URL where you could modify as shared above while if you pressOPEN` you will be directed to a page and you will have to copy the URL from the page and make changes to your URL as shared above.

Hi @Kal_Lam

I am still having trouble. See the screengrab here

Hi @dankaranja,

Thanks for sharing the screen recording, it was helpful to see what you were meaning. When I tested this out, moving between tabs does reset the state of the drop-down menu — I’ll have to check if this is the intended behaviour. With regards to your returnURL issue, I see that this in indeed not working on kf.kobotoolbox.org. I will look into this now and get back to you.

Josh

1 Like

Hi @dankaranja, it seems to be from Enketo’s side to have slightly changed the case of the parameter. Can you please try using returnUrl instead of returnURL and see if that fixes your issue? It is unclear right now if this is going to remain going forward, but should work in the short-term at least.

1 Like

@Josh

Thanks a lot! It worked.

1 Like

@dankaranja great! I have confirmed that return_url is the preferred query parameter moving forward. So although returnUrl currently still works, it may lose support in the near future. I will update our documentation to recommend return_url.

2 Likes