Google maps layers not loading in app

Description

When running geoshape (area) questions in KoBoCollect I cannot get the base layer to run for google maps (any layer). I just get a grey screen where I cannot even see a blue dot for my location, despite the app saying there is 8m or less accuracy and when I mark geopoints they register and save, but nothing appears on screen. Additionally for all other base layers (mapbox, openstreetmap usgs, stamen & carto), changing the map style in settings has no effect. The map is generated using an identical map for each map style, differing only by base layer source. This occurs both online and offline, including when I have saved all relevant areas as offline maps in google maps (not sure if last step makes a difference or not). I am trying to get farmers to mark their property boundaries so need google or other source satellite imagery.

Note: this is different to the problem mentioned for enketo map generation elsewhere as I cannot change the browser security settings in the app (I have already given location permission) and therefore the previous related thread does not solve my problem.

I also attach a picture of the grey google map baselayer.

Steps to Reproduce

  1. Create a question in kobotoolbox under the question type “area”
  2. Save, deploy & load onto device
  3. Open the question & click to greate a geoshape. Try to change baselayer in kobocollect settings under “maps” section

Expected behavior

Base layer appears according to selected base layer type (see step 3)

Actual behavior

Grey screen for google under all map styles and no change in map style on any of other map source options.

Additional details

I am using a Lenovo tab E8 tablet.


- What should topics in this category generally contain?

Information on how to get a satellite base layer to load in kobocollect NOT enketo. Additionally the question is directed at base layer appearance NOT on identifying current location.

- Do we need this category? Can we merge with another category, or subcategory?

No - I have not found a question directly related to this specific question.[![IMG_20190920_154808|375x500](upload://7YY4Pw8vNAEO7vQyRpKNIaEZJZa.jpeg) ](http://)

did you find any solution?? I have the same problem and I also can not see the online map as well, so I would be grateful for any help.

I found no solution! I am still trying to figure out the problem

Hi Both,
Can you try setting up this form for collection on ODK Collect and indicate if the problem persists? Also when you tried other phone types, did this problem persist.

Regards
Stephane

Hi Stephane,

Yes I have already tried both of these with no luck. I set the form up for collection on ODK collect and found the problem persisted on both my tablet and my mobile device.

It worked!

I used ODK collect yesterday and then without any farther modification the map is showing !
I tried this on Samsung tab 10.1 that released in 2019 and my Samsung s9 phone

So I think there is some sort of a bug in the app.

now I am working to make offline maps working :sweat_smile::smile:

type || name || label::Arabic (Ara) || required || appearance
geopoint || GPS || the question || false || placement-map

I didn’t try geoshape … but maybe my configuration above could help you, if not … try to change maps basemap server from (general settings -> maps -> source)

this is working now using ODK collect v1.23.3

Sorry I had misread this. Yes - this does work for me on ODK collect, just not on Kobocollect.

1 Like

Thanks for the information; quite helpful, We will look into the bug

1 Like

yes, I have the same problem as this,

I used ODK collect as well, but with the server and username created by Kobo, and meet the same problem.

looking for a solution!

Hi
Just following up whether this was resolved on your end.
Regards
Stephane

No I have no solution yet except to use ODK collect for the collection

Hi @slevy316, @Zainab_ali, @terry87

Would you mind trying out the following to see if it solves your issue:

In the survey form:
Ensure you have typed maps in the appearance while building your xlsform (or survey form in the Form Builder User Interface).

In the KoBoCollect app:

  • Open KoBoCollect app
  • Click to settings
  • Click General Settings
  • Click Maps
  • In the Source, select Google
  • Get back to the home scree of your KoBoCollect app

You should now be able to view the map (powered by Google Maps) in KoBoCollect.

Making this changes worked for me! Please let us know if it worked for you!

GOOD DAY!

1 Like

HI Kal,

Thanks so much for the step by step instructions.

Unfortunately this did not fix the problem inside KoBoCollect for me. I followed your steps precisely (type maps in appearance, uploaded my form, changed general settings for maps to google) but it has had no effect.

Any more suggestions are welcomed!

Hi @slevy316,

Please checkout the followings then:

  1. Please ensure to active your GPS (location) from the device.
  2. Ensure you have Google Maps app in your device. it? If no please download and updating it before filling the blank form (in KoBoCollect).

Please let us know whether this worked for you. If no, would you mind sharing me your KoBoToolbox user name (in a private message) so that i could test your xlsform in my KoBoCollect android app.

GOOD DAY!

Yes I already have google maps, including target region (tried with maps saved offline and without).

Messaging you individually, thanks Kal!

1 Like

I have experienced the same problem, not showing online maps or mbtiles in the …/layer folder.

I’m using Samsung Galaxy TAB-A

This problem has now resolved on my mobile device, however on the tablets used by our team to implement survey it has not.

We have instead created mbtiles for our study region and saved them on each tablet. This is not a solution but it has helped :slight_smile:

1 Like

Hi, would you mind sharing how you resolved on your mobile device? I have the same problem and have not been able to solve. (Neither can I load mbtiles as a workaround). Thanks,