Guidance_hint cannot be translated in Formbuilder - Multiple languages (translation)


A guidance_hint cannot be translated (directly) in Formbuilder.

Steps to Reproduce

  1. Create a form with more than one language
  2. Create a (text) variable and add a guidance_hint (not hint)

Or import this example:
Hint05 Gudidance XLS Download.xlsx (9.5 KB)

3 View form (in default & 2nd language) : Guidance_hint is only shown in default language.
4. Save form
5 View translation table (Manage translations): Guidance hint NOT there
6. Download XLS and inspect. a column guidance_hint (NO ::language!) is created
(See file above)

Expected behavior

Guidance_hint should be saved as with default ::language, Translation with Formbuilder should be possible.

Actual behavior

At the moment, it is only possible workaround is XLS download and changing guidance_hint column name to guidance_hint::language

As in Formbuilder, a guidance_hint XLS column without ::language will work, for the default language only and is not shown for translation,

It will only show for translation if named as hint::language (via XLS download and re-import)…

Additional details

Tested on OCHA 11/04/2020

The KoBo behaviour is different to _message. A _message text without ::language specification will appear for all languages. (And can after XLS download and changing column_name to ::language be translated.) See example for constraint_message in XLS file abve.

Workaround is to download XSL and change column name to guidance_hint::language (dafault), than re-import.
Hint06 Gudidance XLS Download.xlsx (9.5 KB)
From know on all works fine: Translation is available as Formbuilder field (not on Valdation Criterai, but on Question page) and in translation table.


1 Like

A post was merged into an existing topic: Hint NOT Working in Formbuilder for multiple languages (translation)

Hi Wroos,

I am able to translate the question. However, I am not able to translate choices as it is not showing any option for me to insert the translated language. Kindly help me on this.