How to Apply don't know/None /Refused in Multiple response as Exclusive

Hi Team,

How do i make sure that from the multiple responses question one interviewer does not mentione None/Don’t know/Refused with other mentioned answers,I mean when i mention None to Don’t kno they are exclusive answers?

Regards,
Edward.

Hi Edward,

Here’s a quick way of solving this issue: In essence, you have to allow the user to either select the ‘none’ option (and nothing else) or select any other combination of options. In KoBoForm this would be done through the settings in Advanced properties > Validation logic:

Inline image 1

In the XML this will look like this line:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” constraint=“selected(., ‘NONE’) or not(selected(.,‘NONE’))” jr:constraintMsg=“This is not a valid selection” />

However, you’ll have to make a small change in the XML so it looks like this (changed part highlighted:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” constraint=". = ‘NONE’ or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

If you have more than just one option that needs to be excluded, that’s also possible. In that case the XML constraint part would look like this:

constraint=". = ‘NONE’ or . = ‘DNK’ or not(selected(.,‘NONE’) or selected(.,‘DNK’))"

The new version of KoBoForm we are working on will allow these types of patterns to be set all through the user interface, without needing to go into the XML anymore.

Tino

···

On Fri, Dec 6, 2013 at 12:00 PM, ombun...@gmail.com wrote:

Hi Team,

How do i make sure that from the multiple responses question one interviewer does not mentione None/Don’t know/Refused with other mentioned answers,I mean when i mention None to Don’t kno they are exclusive answers?

Regards,
Edward.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

Will be great to see the modification to
formhub.

Having DNA (does not apply) DNK (does
not know) and RTA (refused to answer) as standard reserve or non-response
codes would be TREMENDOUSLY helpful.

Thanks!

Paul S. Hamlin

Senior Manager, Customer Research

**(920) 495-2363 Mobile

(202) 682-1510 Main Office

(202) 682-1535 Fax
**Contact with Skype
FINCA International (Mailing
Address)

1201 15th Street, NW, 8th Floor

Washington, DC 20005

www.FINCA.org
FINCA International

Connect with FacebookConnect with TwitterConnect with LinkedInConnect with Google+Connect with YouTube

From:
Tino Kreutzer tino....@kobotoolbox.org

To:
kobo-...@googlegroups.com,

Date:
12/14/2013 06:48 AM

Subject:
Re: [KoBo Users]
How to Apply don’t know/None /Refused in Multiple response as Exclusive

Sent by:
kobo-...@googlegroups.com

···

Hi Edward,

Here’s a quick way of solving this issue: In essence,
you have to allow the user to either select the ‘none’ option (and nothing
else) or select any other combination of options. In KoBoForm this would
be done through the settings in Advanced properties > Validation logic:

Inline image 1

In the XML this will look like this line:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_"
type=“xsd:string” required=“true()” **constraint="****selected(.,
‘NONE’)****or not(selected(.,‘NONE’))"**jr:constraintMsg=“This is not a valid selection” />

However, you’ll have to make a small change
in the XML so it looks like this (changed part highlighted:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_"
type=“xsd:string” required=“true()” constraint="****.
= ‘NONE’
**or not(selected(.,‘NONE’))"**jr:constraintMsg=“This is not a valid selection” />

If you have more than just one option that
needs to be excluded, that’s also possible. In that case the XML constraint
part would look like this:

constraint=". = ‘NONE’ or . = ‘DNK’ or not(selected(.,‘NONE’)
or selected(.,‘DNK’))"

The new version of KoBoForm we are working on will allow
these types of patterns to be set all through the user interface, without
needing to go into the XML anymore.

Tino

On Fri, Dec 6, 2013 at 12:00 PM, ombun...@gmail.com wrote:

Hi Team,

How do i make sure that from the multiple responses question one interviewer
does not mentione None/Don’t know/Refused with other mentioned answers,I
mean when i mention None to Don’t kno they are exclusive answers?

Regards,

Edward.

You received this message because you are subscribed to the Google Groups
“Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send
an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups
“Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send
an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.


The message above may contain information that is confidential and/or privileged and is intended solely for the use of the individual to whom it is addressed. If this message has reached a recipient inadvertently, further dissemination is prohibited. Please delete the information and notify the sender by return email or by calling FINCA at +1.202.682.1510.

Hi Tino,

I tried doing this with no success. I have a form with 100 questions and when I tried changing the XML, it showed up with the not selected option leading. I tried to change the order by starting the constraints with value in the list. It then showed up as displayed in the XML, I then made the edits but attempts to upload gave error. Kindly provide further guidance. Thanks.

Sola

···

On Monday, December 16, 2013 7:06:29 PM UTC+1, Paul...@finca.org wrote:

Will be great to see the modification to formhub.

Having DNA (does not apply) DNK (does not know) and RTA (refused to answer) as standard reserve or non-response codes would be TREMENDOUSLY helpful.

Thanks!

Paul S. Hamlin

Senior Manager, Customer Research

**(920) 495-2363 Mobile

(202) 682-1510 Main Office

(202) 682-1535 Fax
**Contact with Skype
FINCA International (Mailing Address)

1201 15th Street, NW, 8th Floor

Washington, DC 20005

www.FINCA.org
FINCA International

Connect with FacebookConnect with TwitterConnect with LinkedInConnect with Google+Connect with YouTube

From: Tino Kreutzer tino...@kobotoolbox.org

To: kobo...@googlegroups.com,

Date: 12/14/2013 06:48 AM

Subject: Re: [KoBo Users] How to Apply don’t know/None /Refused in Multiple response as Exclusive

Sent by: kobo...@googlegroups.com


Hi Edward,

Here’s a quick way of solving this issue: In essence, you have to allow the user to either select the ‘none’ option (and nothing else) or select any other combination of options. In KoBoForm this would be done through the settings in Advanced properties > Validation logic:

Inline image 1

In the XML this will look like this line:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” **constraint="****selected(., ‘NONE’)**or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

However, you’ll have to make a small change in the XML so it looks like this (changed part highlighted:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” constraint="****. = ‘NONE’ or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

If you have more than just one option that needs to be excluded, that’s also possible. In that case the XML constraint part would look like this:

constraint=". = ‘NONE’ or . = ‘DNK’ or not(selected(.,‘NONE’) or selected(.,‘DNK’))"

The new version of KoBoForm we are working on will allow these types of patterns to be set all through the user interface, without needing to go into the XML anymore.

Tino

On Fri, Dec 6, 2013 at 12:00 PM, ombun...@gmail.com wrote:

Hi Team,

How do i make sure that from the multiple responses question one interviewer does not mentione None/Don’t know/Refused with other mentioned answers,I mean when i mention None to Don’t kno they are exclusive answers?

Regards,

Edward.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsubscribe@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.


The message above may contain information that is confidential and/or privileged and is intended solely for the use of the individual to whom it is addressed. If this message has reached a recipient inadvertently, further dissemination is prohibited. Please delete the information and notify the sender by return email or by calling FINCA at +1.202.682.1510.

Hi Sola,
Could you send me your XML and let me know which question it is you’re having problems with? I’ll check to see what the issue is.

Thanks,

Tino

···

On Wed, Jan 15, 2014 at 2:55 PM, Olusola Sanwo osa...@gmail.com wrote:

Hi Tino,

I tried doing this with no success. I have a form with 100 questions and when I tried changing the XML, it showed up with the not selected option leading. I tried to change the order by starting the constraints with value in the list. It then showed up as displayed in the XML, I then made the edits but attempts to upload gave error. Kindly provide further guidance. Thanks.

Sola

On Monday, December 16, 2013 7:06:29 PM UTC+1, Paul...@finca.org wrote:

Will be great to see the modification to formhub.

Having DNA (does not apply) DNK (does not know) and RTA (refused to answer) as standard reserve or non-response codes would be TREMENDOUSLY helpful.

Thanks!

Paul S. Hamlin

Senior Manager, Customer Research

**(920) 495-2363 Mobile

(202) 682-1510 Main Office

(202) 682-1535 Fax
**Contact with Skype
FINCA International (Mailing Address)

1201 15th Street, NW, 8th Floor

Washington, DC 20005

www.FINCA.org
FINCA International

Connect with FacebookConnect with TwitterConnect with LinkedInConnect with Google+Connect with YouTube

From: Tino Kreutzer tino...@kobotoolbox.org

To: kobo...@googlegroups.com,

Date: 12/14/2013 06:48 AM

Subject: Re: [KoBo Users] How to Apply don’t know/None /Refused in Multiple response as Exclusive

Sent by: kobo...@googlegroups.com


Hi Edward,

Here’s a quick way of solving this issue: In essence, you have to allow the user to either select the ‘none’ option (and nothing else) or select any other combination of options. In KoBoForm this would be done through the settings in Advanced properties > Validation logic:

Inline image 1

In the XML this will look like this line:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” **constraint="****selected(., ‘NONE’)**or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

However, you’ll have to make a small change in the XML so it looks like this (changed part highlighted:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” constraint="****. = ‘NONE’ or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

If you have more than just one option that needs to be excluded, that’s also possible. In that case the XML constraint part would look like this:

constraint=". = ‘NONE’ or . = ‘DNK’ or not(selected(.,‘NONE’) or selected(.,‘DNK’))"

The new version of KoBoForm we are working on will allow these types of patterns to be set all through the user interface, without needing to go into the XML anymore.

Tino

On Fri, Dec 6, 2013 at 12:00 PM, ombun...@gmail.com wrote:

Hi Team,

How do i make sure that from the multiple responses question one interviewer does not mentione None/Don’t know/Refused with other mentioned answers,I mean when i mention None to Don’t kno they are exclusive answers?

Regards,

Edward.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsubscribe@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.


The message above may contain information that is confidential and/or privileged and is intended solely for the use of the individual to whom it is addressed. If this message has reached a recipient inadvertently, further dissemination is prohibited. Please delete the information and notify the sender by return email or by calling FINCA at +1.202.682.1510.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

Hi Tino,

I have resolved it. I was using all instead of any in the validation sub section. Thanks.

···

On Wednesday, January 15, 2014 10:33:08 PM UTC+1, Tino Kreutzer wrote:

Hi Sola,
Could you send me your XML and let me know which question it is you’re having problems with? I’ll check to see what the issue is.

Thanks,

Tino

On Wed, Jan 15, 2014 at 2:55 PM, Olusola Sanwo osa...@gmail.com wrote:

Hi Tino,

I tried doing this with no success. I have a form with 100 questions and when I tried changing the XML, it showed up with the not selected option leading. I tried to change the order by starting the constraints with value in the list. It then showed up as displayed in the XML, I then made the edits but attempts to upload gave error. Kindly provide further guidance. Thanks.

Sola

On Monday, December 16, 2013 7:06:29 PM UTC+1, Paul...@finca.org wrote:

Will be great to see the modification to formhub.

Having DNA (does not apply) DNK (does not know) and RTA (refused to answer) as standard reserve or non-response codes would be TREMENDOUSLY helpful.

Thanks!

Paul S. Hamlin

Senior Manager, Customer Research

**(920) 495-2363 Mobile

(202) 682-1510 Main Office

(202) 682-1535 Fax
**
FINCA International (Mailing Address)

1201 15th Street, NW, 8th Floor

Washington, DC 20005

www.FINCA.org

From: Tino Kreutzer tino...@kobotoolbox.org

To: kobo...@googlegroups.com,

Date: 12/14/2013 06:48 AM

Subject: Re: [KoBo Users] How to Apply don’t know/None /Refused in Multiple response as Exclusive

Sent by: kobo...@googlegroups.com


Hi Edward,

Here’s a quick way of solving this issue: In essence, you have to allow the user to either select the ‘none’ option (and nothing else) or select any other combination of options. In KoBoForm this would be done through the settings in Advanced properties > Validation logic:

In the XML this will look like this line:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” **constraint="****selected(., ‘NONE’)**or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

However, you’ll have to make a small change in the XML so it looks like this (changed part highlighted:

<bind id=“A01_MULTI_” nodeset="/yoursurvey/A01_MULTI_" type=“xsd:string” required=“true()” constraint="****. = ‘NONE’ or not(selected(.,‘NONE’))" jr:constraintMsg=“This is not a valid selection” />

If you have more than just one option that needs to be excluded, that’s also possible. In that case the XML constraint part would look like this:

constraint=". = ‘NONE’ or . = ‘DNK’ or not(selected(.,‘NONE’) or selected(.,‘DNK’))"

The new version of KoBoForm we are working on will allow these types of patterns to be set all through the user interface, without needing to go into the XML anymore.

Tino

On Fri, Dec 6, 2013 at 12:00 PM, ombun...@gmail.com wrote:

Hi Team,

How do i make sure that from the multiple responses question one interviewer does not mentione None/Don’t know/Refused with other mentioned answers,I mean when i mention None to Don’t kno they are exclusive answers?

Regards,

Edward.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsubscribe@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.


The message above may contain information that is confidential and/or privileged and is intended solely for the use of the individual to whom it is addressed. If this message has reached a recipient inadvertently, further dissemination is prohibited. Please delete the information and notify the sender by return email or by calling FINCA at +1.202.682.1510.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at http://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/groups/opt_out.

Hi, Sorry can you share how exactly you solve this please?

Hello,
Attention, please: This is a very old thread.

Today this can easily be done in XLSForm (Excel) with a constraint like:
if( selected(., ‘Z’) or selected(., ‘Y’), count-selected(.) = 1, true() ).
constraint_message
NONE (‘Z’) or Don’t know (‘Y’) can only be selected alone. Z and Y being the names of these choices.

You can also use the search function of this forum to find (recent) examples, like
https://community.kobotoolbox.org/t/how-to-add-multiple-constraints-none-and-declined-to-answer-for-multiple-choice-question/14779

1 Like

Thank you a lot for the suggestion !! Work wonderfully