I cannot upgrade my server

I setup kobo-install on my server and when I tried running python3 run.py --update I get this error
so I cannot update my kobo installation

Welcome to the community, @dennohkiragu! Have you gone through this post discussed previously (it should be helpful):

Yes I have gone through all of them, but still I cannot manage to upgrade it

To add on a few details, I currently on version [2.021.09] and I believe the latest version is [2.021.12b] so it should not have a lot of issues upgrading.
Also if I download the latest(kobo-install) release as a zip extract it then and run python3 run.py --setup in the latest version’s directory but change the configurations to what I had before will it update? and if so will it change anything in the database?

I also get this error at times

odk@hq-odk-test:~/Downloads/kobo-install$ sudo python3 run.py --update
fatal: not a git repository (or any of the parent directories): .git
An error has occurred

The --update option will try to fetch the latest files from the repository, so if it’s not a git folder it will return the error you specified. So you need to do a git pull instead of extracting from a zip file.

If there is an existing installation on your system, there should already be a kobo-install folder somewhere.

1 Like

After running sudo python3 run.py —setup , I started getting the git error,so am sure to fix this isue I should pull from git.But @ks_1 is it possible to move from the zip(downloaded) version to the git one without loosing data?

Yeah don’t worry, you will not lose any data as long as you don’t touch the .vols folder.

Create a new folder, run git init. Then add the kobo-install repository as remote and do a git pull.
Then execute run.py --setup from this new folder. One of the questions will ask you for the kobo-docker folder, here provide the same folder as the previous installation.


So I managed to pull the git to my folder thanks for that @ks_1 .But then after running run.py --setup. I got the error

CommandError: Retries exceeded; failed to connect to default database
An error has occurred
I have never selected advanced settings, so I have never changed my passwords.
Any solution for that?

You don’t have to run --update if you have run --setup using the latest files from the repo.

Check this link to solve the CommandError:


okay on it

1 Like

Hey @ks_1 thankyou ,it worked in the advanced section after executing run.py --setup I made sure kobo-docker does not expose backend container ports and also made sure does not run kobo-docker with separate front-end and back-end servers :grinning:


Good to know it’s sorted :slight_smile: