I have the issue with configure the email with kobotoolbox

I have the issue with configure the email with kobotoolbox.

I have installed the docker version of kobotoolbox on my ubuntu server and application works ok, but does not send the email to user to reset the password when user forgot the password.

I configured the SMTP file similar to this:

SMTP set-up onfigurations:







And I can send email from telnet from the server, but kobotoolbox would send the email.

I ran out of ideas. Please help.

what provider are you using ?

I am using Microsoft Office365.

maybe try to use port 25? also did you check your smtp configuration in kobo-deployment/envfiles/smtp.txt ?

1 Like

I only put the email configuration into this file. Where else the email configuration should be? I think I am missing something. Thank you for looking into it.

you should configure the smtp setting from kobo-install by running: python3 run.py --setup

1 Like

I think there was wrong info used during the installation. Is there a way to update email configuration info?

yes you need to go through the python3 run.py --setup and update your info there, if you cant just when the setup start choose to install kobo in another directory or delete the unwated one.


Hi @tlarionova_admin
in your kobo-deployment/envfiles/smtp.txt
what do you have for the bit “email_backend=” text ?

i just made it work
keep the smtp text as it is
make sure you can telnet to gmail
telnet smtp.gmail.com 587
make sure allow less secure apps is enabled in gmail account settings
make sure to install django from pip3
then proceed in python3 run.py --setup and fill the smtp settings as following:
smtp server: smtp.gmail.com
port : 587
username: youremail
password: yourpassword
TLS yes
support email: same as your username

1 Like

Great - im going to try Gamil as i cant get office 365 working.

1 Like

no luck - ill have to see if there is anything in the logs

Its working now - MFA was causing the issue. Office365 SMTP details work fine.
Layer 8 issue in the end

1 Like

Glad to know it worked for you with Office365

1 Like