Invalid character in header content ["authorization"]

Hello community!

I have teams deployed in the field using the same form, with their own usernames and passwords. Form is working for most of my teams with no problem.
They are all using Enketo Webforms.

Some of my users are getting an error message saying:

  • Invalid character in header content [“authorization”]

invalid character in header content

  • This users have variety of devices; an Iphone 6, a Samsung M51, General Mobile 5.
  • We already tried using variety of browsers, Safari, Chrome, Yandex etc.
  • I already checked the permissions for usernames.
  • We already tried clearing cache and history in browsers.

Any idea about this error message?
Thank you in advance.

@hakan_cetinkaya, it could be a browsers issue. If you go through our support article Troubleshooting Enketo Web Forms you should see this link which suggests users to use modern browsers for Enketo.

1 Like

Hello @hakan_cetinkaya,

  • Did you check your form with the Online validator?
  • When, after what action, do they get this error? (Always or sometimes?
  • Are there any special characters in their username or password? (Different to those who have no problems).
1 Like

Hi @wroos,

  • Form works perfectly for other teams, it is in use. The form is valid.
  • They get this error everytime after they use their credentials to access the form.
  • Usernames and passwords are all standard English alphabetic characters.

Also I’ve tried their credentials. It works.

Hi @Kal_Lam,

I also thought that, but even after we download the latest versions of modern browsers. The problem remains.

Hello @hakan_cetinkaya

What action is this exactly? download form? edit? submit? …

Did they type the username and password?
Does their phones themselves have the same language (EN)?

1 Like

Hi @wroos,

There are row-level permissions, so they are trying to open the link of the form itself to fill and submit the form.

We are using Enketo Web Forms, not KoboCollect I don’t know if there are QR - Code’s for Enketo Web Forms?

We did retyped, cleared the cache and history of the browsers, retyped the usernames and passwords.

@hakan_cetinkaya, could you list out the device and their corresponding browsers that show this error?

Hi, here is the list of devices and the browsers:

  • Samsung m51: Chrome, Yandex - Getting error message after logging in.
  • General Mobile 5 Plus: Chrome, Yandex - Getting error message before logging in.
  • Iphone 6: Safari - Getting error message after logging in.

I will create another username and password for these people and will look into more detail.

1 Like