Issue with choices question

Hello Team

checked in both server the issue remain same
2)selfhosted server

There are some answer choices that I keep fixing. Then I save my changes. Then redeploy the survey. But when I preview it the incorrect thing keeps coming up. It’s almost like the answers are linked to each other somehow so when I change them in one item they automatically change in the other.

but i got error out put .

Please check why

Note: For time being i had fixed by downloading and adding option and changing the ID and upload again it works

As a cross check could you do the following to see how the changes are stored:

  • Edit your survey project.
  • Save the change.
  • Deploy the changed project.
  • Download the project as xlsform and then see if the changes are stored correctly.

Hello @Kal_Lam

  1. i try as you said but did not save data created by me , it is creating same question ID for both choices


2)kindly check your end as well by upload and try make changes from UI not from xls


(upload://tl46cUtV4Kq1IpZ7Wzqw4VcqNwe.xlsx) (11.4 KB)

  1. for fix i had did manually by changing id in the xls from and added id and option choices


out put:

Could you share with me a video of your issue so that we could understand it much better?

Hello @Kal_Lam

Please find the video requested

1 Like

@Mdkhamru, could you clone the project and see if the same happens there too?

  1. ya the issue occurs in clone as well

  2. XlS traditional way this been fixed but my only concern was what happened with From builder UI for only this question choice has issue

@Mdkhamru, could you share with me the following (private message) so that I could have a closer look at my end:

  • Username
  • Project name
  • Server (seems like OCHA)

Please check the message sent in person

1 Like

I’ll admit to only a cursory reading here, but it sounds like this bug: Choice list updates when changes are made to the duplicated question · Issue #2936 · kobotoolbox/kpi · GitHub

1 Like

i have same pbm here pls. What can I do?

I have the same problem and have tried cloning but it is still the same issue.

After exiting survey builder and re-entering, the questions change and I have redone them 3 times. I even cloned the survey and redone them twice and the problem/bug persists, Is there something I am doing wrong?