Kobo form could not open

We install kobo on our own server. The only problem we are having is that the open button to open the form is not working and the copy button disappears.

Can someone please help

1 Like

Hi @sheku_munu_kc,

Welcome to the community! Would you mind trying the same form in either OCHA server or HHI server and see if it behaves in the same way.

Have a great day!

Hi together,

we’re currently facing the same issue. Link-Button is missing and Open-Button not functional. Forms are still accessible (all deployed with Enketo) and filled forms are correctly submitted. This applies to all forms.

The problem appeared when our IT was fixing another minor issue. It seems like that when doing the fixes, the Docker containers were updated. Our current setup is:

kobotoolbox/nginx                          latest 
kobotoolbox/kobocat                        2.019.52-final-shared-database
kobotoolbox/enketo-express-extra-widgets   1.77.0-jnm-grunt-workaround  
kobotoolbox/kpi                            2.019.52-final-shared-database
mongo                                      3.4    
mdillon/postgis                            9.5   
redis                                      3.2
Installed with kobo-install, without https-config. 

python run.py --logs were checked with no helpful results.

Maybe a bug in the current Docker images?

Thanks in advance
Daniel

Hi @DSimon
What exactly did your IT guy change? Are you able to trackback the exact issue which could be causing this?

Regards,
Stephane

Hi @stephanealoo,
The initial issue (proxy error) was caused by too many certificate request one of the applications within Kobo (don’t know which one) sent to let’s encrypt (which we use for https instead of the internal config). That has been fixed, but I can’t tell what exactly he did.

Hope this might help…

Regards,
Daniel

1 Like

Glad to know that this is now solved

No, unfortunately its not solved. What I described in the last post, was the initial problem (proxy error), which was solved but somehow the fixing might have caused the current issue (missing Link-Button/Open-Button not working).

So the problem still persists. Maybe the last post was a bit ambigouos, sorry for that!

Regards,
Daniel