Kobotoolbox returning a blank page after clicking the submitted form

The server is having any issues?

I am not beeing able to visualize the submitted forms inside KoboToolBox, when I click them, on table view or map view, the server opens a blank page.

Welcome back to the community @percezione! Could you also share with us a screenshot of the same. Also please let us know the total number of submissions your survey project has that has this issue.

24009 submissions total

This is what the server opens after I click the submitted form.

I am also experiencing the same issue on another account with a smaller form, with very few submissions.

Could you share with us the following information through a private message so that we could have a closer look at your case:

  • Username
  • Project name
  • Server

Regarding the issue for case 1, I could view it without any issues:




Regarding the issue for case 2, i see the report with an error message as shown in the screenshot in the custom report:


However, the data from the DATA>Table can be viewed without any issues:


Note: Please be informed that your custom report is distorted because you have used the select_one_from_file question type which is currently not supported in the form builder UI. There is already a GitHub issue for this. Maybe you could follow the same here:

Thanks Kal_Lam!
I will remove the select_one_from_file from my form.

In the DATA>Table: screen shot, Did you try to visualize a form? By clicking in the eye icon? The issue is when I click the eye icon and the kobo redirects me to a blank page.

This problems still persists, in both accounts

1 Like

Hi @percezione,

I could reproduce your issue (blank page seen while clicking the eye like preview button from DATA>Table) and it seems to be a bug.

Regarding your other concern …

You need not remove them. The only issue is that the form builder UI currently does not support the same. You could still have the data stored safely in your account.

@percezione, please be informed that i have created a GitHub issue for the same. You could follow the same here:

Will however update you once the issue is solved at our end.

1 Like

Thanks KaL_Lam,
You are awesome!

1 Like

Any updates on this issue Kal_Lam?
I saw that magicznyleszek made 2 commits, but the problem persists.

Thanks in advance!

@Kal_Lam Is this bug pertaining to a particular version? I’m planning to upgrade my server to a recent version, which version should I choose to avoid this bug?

@percezione, @ks_1 the issue has still not been resolved. Will let you know when it’s public.

Can you confirm that this issue is with the kpi repo? Do you know which is the last version of the repo in which this is working?

Kal_Lam, are there any workarounds to avoid this bug while developing the form? are the select_one question types that are causing this?

@percezione, @ks_1, the recent release of the announcement should fix your issue. For details please see the announce post:

1 Like

Thanks Kal_Lam, it’s fixed!

Thanks to all developers, this is a great community!

1 Like