Login required


I am the owner of the forms and have given other people permissions to add submissions. Occasionally, when other person opens a form, fill it and then press submit button, kobo says “login required”. Kobo just caches this form. after other person authenticates successfully , submission still does not occur. if that person tries to upload (cached) form manually it again asks for login!

I have noticed that URL changes from kobo.humanitarianresponse.info to ee.humanitarianresponse.info. does this make any differece? how can we recover from asking relogin again and again?


Hi @mskaraca,

Thank you for flagging up your concern and queries related to KoBoToolbox. From your information i understand that you have been using the web browser (computer) instead of the KoBoCollect (android app). I also assume that you have produced a link (to enter the data) through the form builder (by clicking Open). Kindly please try to produce a link (by clicking Copy) in the form builder. You will most probably not receive the message following the latter.

Please let me know if it worked.

It is very good to see answers in kobo community. I have been started to think that (official) kobo support is too weak.

Yes we are using web browser. But I do not share links. our users first login to kobo.humanitarianresponse.info. then they see all the forms entitled to use. They click a form and a new window opens. I noticed that URL changes from kobo.humanitarianresponse.info to ee.humanitarianresponse.info. I have thought that because of this URL redirection a new login required message has shown. Weird thing is that, if user logins, it still asks to login to submit the form!

if we logout and then login, it sometimes works, sometimes not.

Hi @mskaraca,

Thanks for acknowledging! While entering data through web browser you need not provide your user id and password to someone else. Like i advised you in my post earlier, kindly please follow the following steps:

  • Login to your KoBoToolbox account

  • Select the “Projects”

  • Select the appropriate project that you wish to fill data online

  • Choose the “Form” tab and select “COPY” (somewhere at the bottom, near the OPEN tab). Note: Please do not select “OPEN”

  • Once you select COPY, the link to the data entry form will be copied to the clipboard. Now you just need to paste the data entry link to the email and share the link with your colleagues who are responsible for data entry. These data entry staffs/ colleagues are able to fill up the forms multiple times.

Yes, like you said you will be login to kobo.humanitarianresponse.info but once you select the COPY or the OPEN tab you will be directed to the ee.humanitarianresponse.info. Please note that this previous platform is for creating and managing forms and database while the later is a platform for entering online data. However, the important thing you need to understand here is that with COPY you will be able to copy the link of the survey project to the clipboard (which you could paste it somewhere else) while with OPEN you will be able to view and enter the survey project to a new windows tab.

Hope this was helpful for you!


form permissions may change from time to time. so instead of another way (email etc) to inform about forms, we directly require users to login kobo.humanitiarianresponse.info.so that they can easily see and access forms there. so sharing forms with email is not a viable solution here.

we have selected “require authentication to see forms and submit data”. so users need to login. the problem here is that, why transferring from kobo to ee site requires login and secondly why one time auth in ee is not enough

here is the screenshot

We are still struggling with this error
does anybody has a solution or guidance for this


Hi @mskaraca,

Would you mind sharing your xlsform so that i could upload the same in my account and see the reason behind the error message.

So I am running into a similar issue where when I am copying the link from multiple online/offline submissions it shows us this screen and I can’t seem to figure out how to get around it.

Hi @Anderson,

The following discussion discussed earlier might help you solve out the problem:

Thank you that seems to have solved my issue though I’m not sure how that box got selected in the first place since I have had no issues up till recently.

1 Like

This is confusing to me. I have routinely been using FORM > OPEN to enter data, and I see the data in the server database. I also get the message that the data has been submitted to the database. This is the case when I am the owner and also when I am a user with submit privileges.

We have been instructing users to log in to the humanitarian server with their individual login, view the forms for which they have privileges, and enter data using the OPEN button. Alternatively, we send them the URL from the OPEN button and they have to add authentication. We do not use COPY, since it seems to allow any user to enter data without authentication. Am I missing something?

1 Like

Hi @jblackman,

Sorry for the tpyo that i had made previously (& thanks for flagging it out!). With OPEN you should be able to OPEN the survey project in a new windows tab while with the COPY, you should be able to COPY the link of the survey project to the clipboard (computer’s memory) which you could use it (later) by pasting to a new windows browser or even copy the same to an email if you had to send it to someone for the survey!

I would like to add a correction to my prior note and a comment.

COPY, as noted above, and OPEN both use exactly the same URL. COPY simply copies the URL to your clipboard, whereas OPEN opens a new browser window using the same URL. (If you like, you can also copy this URL to your clipboard.) I previously thought that COPY bypassed security and the URL in OPEN enforced it. This is not the case.

We are still testing the “require authorization” feature. It appears that the “errors” as noted by other users are due to persons not having the correct permissions (specifically, ‘Add Submissions’) for the form when authorization is ‘required’.

There is one other possible factor, and that is that the username/password may need to be stored (keychain?, cookies? Enketo?- not sure). I have noticed that when loading a web form after a username and password has once been entered, authentication before submission is not required. (I really wish that this was all better documented, as I have spent many hours trying to figure this out. And yes, I did read the articles on permissions.) Additional comments would be much appreciated.

1 Like

You got it correct @jblackman! GOOD DAY!