ODK-Briefcase don't jet open


I’m using ODK-Briefcase to encrypt and decrypt my forms. Facing this question, I’ve reached to configure (Settings tab), see the form’s list (Pull tab, with success), but not Push my forms (only “Partially succesful upload” obtained in the Push tab). Some years ago I’ve reached to complet all the process, but not now.
To try with different manners, I’ve closed ODK-Briefcase some days ago and now Briefcase don’t jet open,
I’ve see the post “ODK Briefcase will not open” and consequently, I’ve update the Java version to v8 and the policy file, but it have no effect. ODK-Briefcase don’t open. In fact, the program does nothing.

Steps to Reproduce

1… Double click on the file “ODK-Briefcase-v1.15.0.jar”. After some seconds, nothing occurs
2. Alternatively, with a command prompt window, I’ve navigated to the referred file folder, and I’ve tried to start the program by typing it in the command window. Nothing occurs!
3. I know that newer versions of ODK like v1.17.4 or v1.18.0 are not suitables for encrypt-decrypt, but I’ve tried to see if its starts: no, even theses versions don’t start!!

Expected behavior

I expect the screen of ODK-Briefcase opened after double click

Actual behavior

Actually, ODK-Briefcase don’t start, so it does nothing

Additional details

Initially I’ve had installed Java v6, but ODK-Briefcase don’t start; I’ve updated to Java v8, but the problem persists

Thanks in advance!!

  • What should topics in this category generally contain?

  • Do we need this category? Can we merge with another category, or subcategory?

To continue trying, I’ve copied the ODK-Briefcase-v1.15.0.jar file and I’ve pasted it in a different folder. I can see now the log file (previously it was unchanged), and it have what I thing it’s a interesting information: it indicates “Failed to launch GUI”. See also the follow line, “java.lang.IllegalStateException: Duplicate key org.opendatakit.briefcase.model.FormStatus@52e7a6b2”

In addition, looking in the web for “org.opendatakit.briefcase.model.FormStatus@52e7a6b2”, I have founded a topic at forum.getodk.org explaining, by dicksonsamwel a possible solution: change the name of the ODK storage directory; efectively, after do that, ODK-Briefcase is now showing its GUI.
Thanks a lot!!

1 Like

@aortegon, :bowing_man: thank you for sharing the solution to your issue with the entire community!