PDF Preview Not Working on Public Kobo Server: Possible 502 Server Error

Hi all,

Encountering an issue with the function to open submitted responses in .pdf format. When navigating to the Data tab and using the preview function, a popup box appears briefly (Capture1) before being taken to a blank page (Capture2). On at least one occasion, the blank page has shown a 502 error (Capture 3). Previously, this function has worked as expected, and continues to do so with other forms. I have tried this function with multiple browsers and devices, clearing cookies and cache, however this has not worked.

From the community forum I thought it might be an issue around having re-deployed the survey, but I uploaded and deployed a new survey entirely and I’m experiencing the issue right away.

Would be grateful for advice as the PDF report is crucial for my project.
Thank you in advance,

Capture 1

Capture 2

Capture 3

@sjed1, would you mind sharing with us the following a private message:

  • Username
  • Project name
  • Server

You could send me a private message as outlined in the post discussed previously:

1 Like

@sjed1, I could also observe a blank page when the eye like preview was clicked. Would you mind doing the following to see if it can be replicated to other project by following the instructions outlined below:

  • Download the xlsform of the project that is having issue.
  • Upload and deploy as a new project (with a new name). This is to check if we are able to get the same issue in this project as well.
  • Make a dummy submission.
  • Then again press the eye like preview to see if you are able to see the same issue in this new project too.

OK as a cross-check, would you mind validating your xlsform through this online-validator to see if there are any syntax issues?

The issue appears to be related to the Matrix Response type question as built according to the support documentation. (Question Matrix Response Type — KoBoToolbox documentation) See Capture 1

When I remove the Matrix from the survey, the preview works again. This is odd, however, as previously the preview button has worked with a Matrix in the survey.

Capture 1

OK, will have a look at it to see if there is anything affecting the project?

Hi @sjed1
You can ignore the first error you are seeing. However, on the second error, have you amended the specified group to ensure you address the problem which is clearly highlighted i.e. no label