Problem lunching server

I am trying to launch server on my machine. I followed all the steps mentioned here . I have installed virtualbox and vagrant. After that I ran the command “vagrant up” in “dist-kobo-devel” directory from command prompt. It ran successfully and there was a virtual machine in my virtualbox with name “dist-kobo-devel-master”. So i ran the VM and it asked me for login details and I put the username-vagrant and password-vagrant. It logged in successfully and when i tried to run any vagrant command it showed me the message "The program ‘vagrant’ is currently not installed. To run ‘vagrant’ please ask your administrator to install the package ‘vagrant’ ".

And the 3rd step mentioned in the above link contains the link http://localhost:8000/ where we have to login, but the link is not available. So my question is do we have to run this link on our local machine or on the virtual machine in the virtualbox?

I hope that I will get solutions to my problem as soon as possible. Thanks in advance.