Problems loading drafts

I sent this to the support email, but it tells me to post it in here…
Good night, I hope you are doing fine.

I have to report that one of my coordinators is having troubles loading drafts, there’s a message that tells her to communicate to the support email and notify that there is an error:

“TyperError: Cannot read property “querySelector” of undefined” (There’s a photo inserted in this email)

The link of the form is:

This is happening in google chrome.

She exported the 4 drafts, she can send new forms, but cannot access drafts, none of them. It is vital to have this function for the form…

Hope you can help me solve this soon.

Thank you in advance

Hi @analucia_espinoza,

Looking at the screenshot you have shared, it seems like you are not able to load the draft form that was saved previously. Is this the issue you are facing?

Have a great day!

Yes, My coordinator can’t load the draft, to finish the form, plus, I’m facing the same type error trying to load the edit version in the platform when I try to access the loaded forms…

Also, when I open a new form I have some note type fields that look a lot different from the normal version… Is there something new in the platform? It has a lot more space than it used to

El El mié, 19 de ago. de 2020 a la(s) 1:44 a. m., Kal_Lam via KoBoToolbox Community Forum <> escribió:

Hi @analucia_espinoza,

Could you share with us the screenshot of the issue you are having at your end. It would be helpful.

Have a great day!

The exact same error message that my coordinator is facing to load drafts:

El El mié, 19 de ago. de 2020 a la(s) 4:11 a. m., Kal_Lam via KoBoToolbox Community Forum <> escribió:

Hi @analucia_espinoza,

That is you have some filled up forms stored and saved in the browser that is still not sent to the server, you try to open it and then you get this error message.

Have a great day!

Not true, this is the same navigator and my end…

I don’t even send forms why should I have the issue of unsent forms???
Of course my coordinator has some unsent forms… the ones she has on drafts that she CAN’T access to because of this error message…
It is VITAL that we can save drafts and that I can access forms to edit.
I tried changing my navigator, and cleaning it but I get the same issue…
I really need to solve this as soon as possible… both for me and my coordinators. PLEASE!!

If I close this error the form is completely empty!!!

El El mié, 19 de ago. de 2020 a la(s) 5:10 a. m., Kal_Lam via KoBoToolbox Community Forum <> escribió:

Hi @analucia_espinoza,

FYI, I am able to load your survey form without any issue …

Could you let me know the time when you see the error message so that i could look at it more carefully.

Have a great day!

The problem is not loading the forms the first time, the problem is getting the previously saved drafts… and getting the edit version in the platform…

El El mié, 19 de ago. de 2020 a la(s) 5:43 a. m., Kal_Lam via KoBoToolbox Community Forum <> escribió:

Hi @analucia_espinoza and @Kal_Lam,

I have faced the same error when I tried to edit the previously saved draft.

Dear @analucia_espinoza, it is possible to share with us your xlsform to try to explore the reason of this issue.

1 Like

Hi @analucia_espinoza, cc: @Ysr3322

It should take some time but i could load the same (draft submission that was saved in the browser) at my end … FYI:

However, it would be good to see if there is any complexity in the xlsform itself as i tested the same with a normal dummy project and could edit the same normally (without any issue). Have you tested the same (with a normal dummy project) at your end @analucia_espinoza @Ysr3322?

Have a great day!

Well, I tried with a less complex project and it loads, is it possible that the platform has some changes that invalidates my form? Since I see there’s been a change in the way I see it deployed

Is there a non supported function in this version?

El El mié, 19 de ago. de 2020 a la(s) 6:29 a. m., Kal_Lam via KoBoToolbox Community Forum <> escribió:

Hi @analucia_espinoza,

Will explore and get back to you soon. In the mean time would you let us know if you were able to load the forms like i did with the form that you shared. It takes a bit long time but you should be able to load them.

Have a great day!

Hello there ,
i got the same issue , i try to do this steps to solve the issue
1 remove all regex
2 remove almost all the calculation
with no change
, trying to find a solution with no luck till now
if you find the root of this issue please share it

Hi @omaribilal,

Welcome to the community! Could you kindly share with us a screenshot of the issue you are facing so that it would help the community to understand your issue. Would you also mind sharing the data entry link so that we could try it at our end.

Have a great day!

Hi again

the first error i got was the same as this thired

TypeError: Cannot read property ‘querySelector’ of undefined

after some modification on the XLS i got this one

Screenshot_2020-08-19 Enketo Express for KoBo Toolbox

Hello Again ,
I try the same survey on unhcr server it works fine .
on humanitarianresponse server it still not working .

Hello @omaribilal how are you? Noo :frowning: ! I haven’t found any solution yet…
I’m trying to load the same xls form in a new project… and it was implemented, so in theory it should be working fine, because all the structures were recognized …
But no idea…
I don’t have an unhcr server :frowning: !

But I really need to have access and edit some of the forms…

I don’t know if @Kal_Lam can have my information (account and password) and see for himself :frowning: ! This is vert worrying for our office.

Hi @analucia_espinoza,

I would like to ask you how many languages does your form have?


Hello @Ysr3322
Just spanish!