Pulldata working with webform but not working with Collect app

Hi, did you finally made it work? I have the same issue, pulldata is working fine in web, the info is showing; but in the kobocollect app it is not showing the data. I have already check for the csv format and is fine, I have save it as UTF-8 csv.

Hi, I’m having the same trouble. I have already check for my csv, making sure is UTF-8 format, and changing the calculate type to text type as I found in other questions in the forum. But I still not being able to see pulled data in the app (it is working fine in web).

Welcome to the community, @lpsolerf! Could you share your XLSForm (the part that holds the pull data function) and the CSV file? Maybe the community should be able to troubleshoot your issue.

Hi. @Kal_Lam,
listalideres.csv (4.5 KB)
Lideres.xlsx (31.4 KB)

Never mind, I found the issue. Seems that excel in spanish saves the .csv using ; (semicolon) as separator, so it seems that it works in web but not in app. So I had to change my csv using concat function to use , (comma) as separator, and it works now.

@Kal_Lam …I seem to have a similar issue, i tried the proposed solution above and it is not working. For me the pulldata functionality is working well when previewing the form on web, however on kobocollect android app it is not even opening the blank form and giving me this error message

Could you try to follow the hint from above and replace ; by comma.


Thanks … i tried that and it did not work initially. i had to re-do the csv and using a different MS Office package that uses “,” not “;” and it worked. …

1 Like

If your csv doesn’t use ; in text content, you could also solve the problem with the Excel replace function.
Normally, there is a Excel export function comma separated
But this format seems to have limits for languages.

1 Like

Thank you for this tip ! The concat option finally worked for me as well ! Thanks!

1 Like

Hola, Puedes explicar como hacer este cambio ¿hay que hacerlo en xls de formulario? o en CSV?