Receiving error message while building a survey project

I am facing JSON errors after installing “select_one” with “choice_filter” function.

  • Setting several levels of the address (province, city, ward, etc.)
  • Filtering list of each item based on the choice (province filters city, city filters ward, etc.)
  • Add conditions in “choice_filter” in “survey” sheet as well as conditions in “choice” sheet (set province, city, ward at the head of the sheet and add corresponding numbers in the list)


I have tried to solve the issue by referring some threads like these, however I could not solve the issue for a few days.

Problem to see the overview (Error message seen while previewing survey form)

Unexpected token < in JSON at position 0

I woulld like to upload the xls file for your reference but a new user is not allowed to upload it. Could you kindly let me know how I can send it via private email?

Have you validated your xlsform through this online validator? It should give you a clue on what is causing the error message during your deployment.

Yes, I have tested it and it returned no error messages. I could launch the questionnaire from the generated url; however it could not be opened in Kobotoolbox.

I have tested to change the browser, to clean up cashes of my browser, tried to find any characters which may cause the purse error, and so forth.

Preview displays the questionnaire correctly but it happens merely.

@hideoshiraishi, would you mind sharing with us the following information through a private message so that we could have a closer look at it:

  • Username
  • Project name
  • Server

However, fortunately or unfortunately, it does work well without any error messages though I have not changed the XLS file since I posted.

1 Like

@hideoshiraishi, please feel free to reach us back if the error persists.