Server Error (500)

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

Hi.

  1. Preview the form to see if it is okay.

  2. Download the form as an excel file and then re-upload on your account. Then deploy.

If the problem still persist.

  • Create a simple form of about 2 - 5 questions.

  • Deploy the form.

  • Replace the deployed form with your original form.

  • Redeploy the form.

Note: I am only a Kobotoolbox user.

Alex

···

On Jan 29, 2018 9:10 PM, “Ecociate Consultants” ecoc...@gmail.com wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

–

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsubscribe@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at https://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/d/optout.

Dear Alex,
Thanks for your kind suggestion, let me check with this and i will get back to you
Regds
Sudhir

···

On Tuesday, January 30, 2018 at 3:15:31 AM UTC+5:30, Alex Onatunji wrote:

Hi.

  1. Preview the form to see if it is okay.
  1. Download the form as an excel file and then re-upload on your account. Then deploy.

If the problem still persist.

  • Create a simple form of about 2 - 5 questions.
  • Deploy the form.
  • Replace the deployed form with your original form.
  • Redeploy the form.

Note: I am only a Kobotoolbox user.

Alex

On Jan 29, 2018 9:10 PM, “Ecociate Consultants” eco...@gmail.com wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

–

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at https://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/d/optout.

Dear Alex,
I tried the way you suggested, but could not work, even i could not able to download the form in XLS format the time i am getting Internal Server Error 500
However, i created new form with 2 question which has deployed successfully, Now can you please suggest how “Replace the deployed form with your original form”
Hope to hear from you soon
Thanks
Regards
Sudhir

···

On Tuesday, January 30, 2018 at 3:15:31 AM UTC+5:30, Alex Onatunji wrote:

Hi.

  1. Preview the form to see if it is okay.
  1. Download the form as an excel file and then re-upload on your account. Then deploy.

If the problem still persist.

  • Create a simple form of about 2 - 5 questions.
  • Deploy the form.
  • Replace the deployed form with your original form.
  • Redeploy the form.

Note: I am only a Kobotoolbox user.

Alex

On Jan 29, 2018 9:10 PM, “Ecociate Consultants” eco...@gmail.com wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

–

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at https://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/d/optout.

go to the form page for your test survay and press the replace xls file button that looks like this:

···

On Tuesday, January 30, 2018 at 10:23:57 AM UTC+1, Ecociate Consultants wrote:

Dear Alex,
I tried the way you suggested, but could not work, even i could not able to download the form in XLS format the time i am getting Internal Server Error 500
However, i created new form with 2 question which has deployed successfully, Now can you please suggest how “Replace the deployed form with your original form”
Hope to hear from you soon
Thanks
Regards
Sudhir

On Tuesday, January 30, 2018 at 3:15:31 AM UTC+5:30, Alex Onatunji wrote:

Hi.

  1. Preview the form to see if it is okay.
  1. Download the form as an excel file and then re-upload on your account. Then deploy.

If the problem still persist.

  • Create a simple form of about 2 - 5 questions.
  • Deploy the form.
  • Replace the deployed form with your original form.
  • Redeploy the form.

Note: I am only a Kobotoolbox user.

Alex

On Jan 29, 2018 9:10 PM, “Ecociate Consultants” eco...@gmail.com wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

–

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+...@googlegroups.com.

To post to this group, send email to kobo...@googlegroups.com.

Visit this group at https://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/d/optout.

Hi

I’m getting the same problem with my questionnaire of 192 questions. Server error 500 is coming for both downloading XLS file and deploy.

The Kobo team is just not addressing my queries (sent multiple times).

Please advise on how to proceed further.

···

On Tuesday, 30 January 2018 01:10:47 UTC+5, Ecociate Consultants wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

Hi
I have looked at your form both on KoboToolBox side and on the group. The issue seems to be form itself. I suspect that it is the issue where you mixed two languages on the same question text instead of including the language separately as advised within the article on adding languages. If the two languages were in the same alphabet it may work. However I see you have used English and Arabic alphabet. So the issue here is not the system but rather the form. I have also seen you tested a small questionnaire and it worked well. My suggestion would be you try loading the English only and adding the arabic language as indicated within our articles.

Regards

Stephane

KoboToolBox Support

···

On Thursday, April 5, 2018 at 9:44:07 PM UTC+3, sarfr...@gmail.com wrote:

Hi

I’m getting the same problem with my questionnaire of 192 questions. Server error 500 is coming for both downloading XLS file and deploy.

The Kobo team is just not addressing my queries (sent multiple times).

Please advise on how to proceed further.

On Tuesday, 30 January 2018 01:10:47 UTC+5, Ecociate Consultants wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

Hi
Stephen I have now removed the Arabic language text but the problem is still there. Here is link https://kobo.humanitarianresponse.info/#/forms/aL7G8aQvumTzZ8nA39c8Vu/edit.

···

On Fri, Apr 6, 2018 at 12:24 AM, Aloo Stephen stepha...@gmail.com wrote:

Hi
I have looked at your form both on KoboToolBox side and on the group. The issue seems to be form itself. I suspect that it is the issue where you mixed two languages on the same question text instead of including the language separately as advised within the article on adding languages. If the two languages were in the same alphabet it may work. However I see you have used English and Arabic alphabet. So the issue here is not the system but rather the form. I have also seen you tested a small questionnaire and it worked well. My suggestion would be you try loading the English only and adding the arabic language as indicated within our articles.

Regards

Stephane

KoboToolBox Support

On Thursday, April 5, 2018 at 9:44:07 PM UTC+3, sarfr...@gmail.com wrote:

Hi

I’m getting the same problem with my questionnaire of 192 questions. Server error 500 is coming for both downloading XLS file and deploy.

The Kobo team is just not addressing my queries (sent multiple times).

Please advise on how to proceed further.

On Tuesday, 30 January 2018 01:10:47 UTC+5, Ecociate Consultants wrote:

Dear All,
I have created a survey of 146 question, but i am unable to deploy, at the time of Deploy i am getting error as below, kindly suggest to fix it, i spent lot of time to address it, i had also created Clone of the project but not working.
Please suggest how to fix.
Hope to hear from you soon
Thanks
Rgds
Sudhir

–

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsubscribe@googlegroups.com.

To post to this group, send email to kobo-...@googlegroups.com.

Visit this group at https://groups.google.com/group/kobo-users.

For more options, visit https://groups.google.com/d/optout.

–

Best regards

Dr. Mariyam Sarfraz

Assistant Professor

Health Services Academy

Cell: (92) 343 7776777

Office: (92 51) 9255590

E-mail: Sarfraz...@gmail.com
Skype: mariyamsarfraz

https://au.linkedin.com/in/mariyam-sarfraz-a8ab3a19

1 Like

Hi everyone,

I just had the same symptoms as OP. None of the tips I found could solve the issue (I also was not able to pull the XLS form). I tried to just recreate the whole form as a new survey, copypasting each question. That worked without problems. It makes the underlying reason for the error even more mysterious, but in any case, it worked. I recommend trying if all else fails.

Best,

K

Hello anyone who managed to resolve this issue as i have just also received the same error and this is after testing if the tool is ok.

It’s always good to test your xlsform through this online validator to see if any syntax errors are present within your xlsform that is causing the issue.

Sure that’s what i have used to validate but still getting an error.

Maybe this post discussed previously should also give you a clue of the syntax error that could happen at your end:

Dear Kal_Lam

I am having issues opening all my accounts on kobo humanitarian. The issues has started in my account “yvesmorel17” after deploying a form. Now, I am not even able to log into my account. You can find on the image the issue. Is it possible to help me?

Regards

Welcome to the community, @yvesmorel17! The server is back again! Apologies for the inconvenience caused!

You are the best. Thanks

1 Like