SOS **Lost sent forms**

We’ve realize that one of my coordinators is sending forms and they don’t appear in my data, I don’t know why is this, I’ve told him to look if the forms are in queue but they’re not, he tells me that he even saw the message “Form Sent”. I’m very worried, he even used two different devices, and the other submissions appear to be fine.

Hi @analucia_espinoza,

Please be informed that we have stored the information you have provided previously and have edited your post as to make your account secure.

Apart from the information provided, would you also mind proving us with additional information:

  • Browser you are using (if possible the browser version as well)
  • OS the device use

Have a great day!

We solved it! Thank you anyway

1 Like

could you share, HOW you solved it, please?

1 Like

We send them again, not really “solved” the issue, but we were in a hurry!

1 Like

Dear Analucia
how could you send again, normally you can only send a filled (and finalised) form once, i think?
Best regards

Hello wroos!
We refilled another form with the same information

I am experiencing the same problem of lost data yet under the “send finalized forms” it is showing form sent.

How can this be resolved?

Welcome to the community, @wallace! Would you mind sharing with us the screenshot of your Collect android app that has data under Send Finalized Forms?

Hello Team.

We went ahead to export data into xls and on further scrutiny, we could see the data in the exported xls sheets although it wasnt beiing displayed among received data on the server.



So you mean the data was there safe?

Yes. It was there in the exported xls sheet although it wasn’t displayed among received data.

@wallace, if i read you correctly you mean to say that the data is there in when you download your data as XLS format but the submission counter seen in server is not correct?

Dear Kal_Lam,

That’s true.


In this case, would you mind sharing with me the following (through a private message) so that we could have a closer look at it:

  • Username
  • Project name
  • Server

Hello Kal_Lam,
I am having this same issue. I have sent a number of forms to the server. They all say they sent, but I do not see all of them on my server; I am missing one. Please advise as to what I should do.

Welcome to the community, @akhess! Could you provide me the following through a private message? Maybe I could have a closer look at your case.

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously: