Submission service on data server not found. (404)

Hello, I’m getting the following error. Please help

Screenshot from 2024-06-26 13-53-38

Hi @paani,

Which server are you using?

1 Like

I’m using the


@paani, kindly please be informed that 404 shows up when a user attempts to access a project that does not exist on the server. Could you kindly check to see if the project is still there or has been archived? You may also need to see the URL to see if there are any typos in it.

1 Like

@Kal_Lam I can access the form but when I enter the data and Submit, the above error occurs

Hi @jnm I’m facing the same error. I am unable to make any submissions to the form.

@paani, is it a new submission where you are having submission issue or is it an existing submission when you wish to edit the submission on the server?

Yes, it’s a new submission. When I click submit, I get this 404 error.

@paani, are you on a self-hosted KoboToolbox server?

@Kal_Lam No. I’m using the EU server.

@paani, what is the total number of questions you have for this project? Have you validated your XLSForm through this online validator to see if there are any syntax issues in your form?

Yes, I’ve validated the form, and there are around 25 questions. The form is deployed without any errors. The form is opening as well.

1 Like

@paani, my first impression here, when I tried to troubleshoot your issue, is that I see an issue with your CSV file. See the screenshot below:


Try to replace your CSV file with a clean one and that should solve your issue.

I think thats an encoding issue. Because I can see the CSV file perfectly fine. And the values also come into the form in a clean way when I use the pulldata function