Submitted loading error


when I open any submitted form there’s an error message, could someone tell me what’s it and how can I solve it?
Kobo error


@iraq_habitat, I would probably say it could be a syntax issue in your xlsform. Have you validated it through this online validator? Feel free to reach us back if you are still not able to find the issue.

Could you, please, provide the part of your form with the cited expression (Could not evaluate …). Is this in a calculate type? You may try to change it to integer to see if it works.

I checked through the online validator and there was no issue

If this is the case, please feel free to share your xlsform. If you feel your xlsform should be treated confidentially, please share it through a private message.

As a quick workaround would you mind clearing the cache of your browser and see if it works? Besides, pleas also let us know the browser you are using? Try using the latest version of your browser by upgrading if it’s lagging behind.

I did clearing the cache of my browser but still the same error appears, and I’m using Google browser with last updated version.

1 Like

Could you also share with me the following through a private message so that I could have a closer look at your issue:

  • Username
  • Project name
  • Server

So you say this basically happens when you try to edit submission in the server? Did I get you correctly?

Yes , this happens when I try to edit submissions

1 Like

@iraq_habitat, as a quick check would you mind trying the following:

  • Clone the project as a new dummy project
  • Create some (maybe only one would also work) dummy submission
  • Try editing the submission in this dummy project

This would allow us to identify if there were any redeployment issues if the survey project has any redeployments.

I tried with clone version still the error appears. there’s some submissions of old form version, is that make this error? however in this clone form these submissions is not available but still has the error

So you mean when you clone the project and deploy it as a dummy project and then submit some dummy submissions too you are not able to make edits to the submitted forms that are present in the server?

No, I’m be able to edit it but the same error appears when I try to edit it,

Hi @iraq_habitat
Could you please try this form as a new form and see if you get the same errors. I am trying to identify if the issue is with the leading underscores for the names?

a2pZ7owPUeokhdpV8c7bA2.xlsx (46.8 KB)


1 Like

When I try to deploy your xls this error appears

Hi @iraq_habitat
I have slightly amended this. Kindly try this.a2pZ7owPUeokhdpV8c7bA2.xlsx (46.7 KB)


it’s deployed, but still, I have the edit loading error

Hi @iraq_habitat
Can you remove the row with this formula and test the form?


Hello @iraq_habitat @stephanealoo ,
Here is a stripped down version, working and deploying.
Problem seems to be around? (Not in this row)
new01.xlsx (37.5 KB)

I can also deploy the full last “amended” version from @stephanealoo (see above)! (And also download and upload it again.)

1 Like

Yes when I remove most of the “other” option then it works

1 Like