There was an error loading enketo when trying to edit all forms in all accounts


I am get this error whenever i try editing a submission. i have tried using different acconts and different forms but all give the same error message

Steps to Reproduce

  1. Got to any form
  2. Go to the list of submissions
  3. Select any submission and try to edit

Expected behavior

The submission should open allowing me to edit

Actual behavior

The submission seems to load but stops abruptly with the error message “There was an error loading enketo”

Additional details

At first i thought it was a browser problem but the problem was replicated in different browsers. Thin i tried opening a different account and got the same error

- What should topics in this category generally contain?
Errors loading Enketo forms

- Do we need this category? Can we merge with another category, or subcategory?
Probably, if there is a general category where this can be contained

@ndechi_maro, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server
  • Survey URL that returns the loading error issue

Note: You could share with me a private message as outlined in the post discussed previously:

HI @Kal_Lam, I have the same error and when searching for this in the forum, I see that it happened a few times but cannot find any solution. Could it be linked to the fact that the form uses a select_one_from_file? Should I send you the username/project/server as well privately?


Hi @Kal_Lam, We are also experiencing this same issue. What would be the next step to getting the issue resolved?

@dianedetoeuf, @nancyv, this could be a glitch in the system. But if you are constantly seeing this issue, please feel free to provide me with the details requested earlier:

Maybe I could have a closer look at it.

But when checking one of the user’s issues, I did not see anything there:

Hello, I met the same issue recently as well. This has not happened before April. Do you have any idea why this happened? I asked my friend if they encounter the same issue with their form, turns out they don’t. But when they click edit on the form I made, the ‘There was an error loading Enketo.’ message showed up again.

I’d like to send you a private message but the option does not show up. I wonder if it’s because this is a new account?

Hello @Kal_Lam were you able to identify the problem or a walk around? We have a lot of data that is waiting and that we cannot work on because of this problem.

Hello Kal, we are having the same problem when trying to edit a record. I was able to corroborate it in other accounts that we manage and it only appears in one of these. In this account we use .csv files as a dropdown list. Could that be the problem?

Good news, we validated the XLSForm through the ODK online validator - XLSForm Online v2.x and it showed that it did not support the search(‘’) function. Therefore, I proceeded to replace it with the “autocomplete” function in the appearance column and everything seems to work normally, we can now edit the forms again.

Error: Question ‘Codigo_Centro’ is a select from file type, using ‘search()’. This combination is not supported. Remove the ‘search()’ usage, or change the select type.

1 Like

@PiresJ, :bowing_man:

@ndechi_maro, @dianedetoeuf, @nancyv, @ysmwy94, @PiresJ, we are trying to investigate and find the root cause of this issue but in the meantime, you could follow the following steps to fix it at your end:

  1. Download the form as XLS
  2. Validate it against the online validator
  3. If any issues are seen, fix it
  4. Import that XLSForm file to the same project (“Replace form”)
  5. Redeploy
  6. Try editing the submissions