Time problem

Good day.

I experience the following problems with KOBO. I did mention it to
Neil Hendrick and he ask me to post here.

With Time selection on phone, in stead of starting at current time ex.
16:30, phone show 4:30 as default. Date is current though.

Upload to aggregate:

The Date only selection, the date is correct, but the time show 00:00 UTC in the cell.
Same for time. Time is correct, but date falls to 01 Jan 1970.

I do want only the date or time respectively on the spreadsheet cell.
How can I change it?

Exporting from Aggregate to CSV, I get what I see, but running it
through Kobo post processor, the heading for the cells and cells, gets
chucked out seemingly randomly.

I am using Open Office Calc, import comma seperated UTF-8.

Any help will be much appreciated.
Regards

Hi!

Could you post your original xml survey so we could check it re the time and date issue?

KoBoSync (formerly known as the post processor) is creating the columns in the transcribed CSV file pretty randomly, it doesn’t follow the original order. Part of that is that the XML instances saved by the phone always only contain the headers of the fields where it contains any data, so if the first 30 instances didn’t have data for the field ‘current school’ but the 31st does, the ‘current school’ column in the CSV will only be created when the 31st XML is transcribed. That’s because KoBoSync doesn’t look at the original questionnaire but only the resulting XML data. You can sort the columns into a better order in Excel by transposing the whole table first and sorting the columns, the transposing everything back, or by doing other tricks in Excel such as hlookups from a separate sheet or file.

Tino

···

On Sat, Oct 22, 2011 at 5:53 PM, Bergie bergi...@gmail.com wrote:

Good day.

I experience the following problems with KOBO. I did mention it to

Neil Hendrick and he ask me to post here.

With Time selection on phone, in stead of starting at current time ex.

16:30, phone show 4:30 as default. Date is current though.

Upload to aggregate:

The Date only selection, the date is correct, but the time show 00:00 UTC in the cell.

Same for time. Time is correct, but date falls to 01 Jan 1970.

I do want only the date or time respectively on the spreadsheet cell.

How can I change it?

Exporting from Aggregate to CSV, I get what I see, but running it

through Kobo post processor, the heading for the cells and cells, gets

chucked out seemingly randomly.

I am using Open Office Calc, import comma seperated UTF-8.

Any help will be much appreciated.

Regards

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to kobo-users+...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/kobo-users?hl=en.

How do I post it to Google groups? I don't see an option to add a
file. Should I copy and paste as a text?

···

On Oct 24, 12:03 pm, Tino Kreutzer <tino.k...@gmail.com> wrote:

Hi!

Could you post your original xml survey so we could check it re the time and
date issue?

KoBoSync (formerly known as the post processor) is creating the columns in
the transcribed CSV file pretty randomly, it doesn't follow the original
order. Part of that is that the XML instances saved by the phone always only
contain the headers of the fields where it contains any data, so if the
first 30 instances didn't have data for the field 'current school' but the
31st does, the 'current school' column in the CSV will only be created when
the 31st XML is transcribed. That's because KoBoSync doesn't look at the
original questionnaire but only the resulting XML data. You can sort the
columns into a better order in Excel by transposing the whole table first
and sorting the columns, the transposing everything back, or by doing other
tricks in Excel such as hlookups from a separate sheet or file.

Tino

On Sat, Oct 22, 2011 at 5:53 PM, Bergie <bergi...@gmail.com> wrote:
> Good day.

> I experience the following problems with KOBO. I did mention it to
> Neil Hendrick and he ask me to post here.

> With Time selection on phone, in stead of starting at current time ex.
> 16:30, phone show 4:30 as default. Date is current though.

> Upload to aggregate:
> >> The Date only selection, the date is correct, but the time show 00:00
> UTC in the cell.
> >> Same for time. Time is correct, but date falls to 01 Jan 1970.
> I do want only the date or time respectively on the spreadsheet cell.
> How can I change it?

> Exporting from Aggregate to CSV, I get what I see, but running it
> through Kobo post processor, the heading for the cells and cells, gets
> chucked out seemingly randomly.

> I am using Open Office Calc, import comma seperated UTF-8.

> Any help will be much appreciated.
> Regards

> --
> You received this message because you are subscribed to the Google Groups
> "Kobo Users" group.
> To post to this group, send email to kobo-...@googlegroups.com.
> To unsubscribe from this group, send email to
> kobo-users+...@googlegroups.com.
> For more options, visit this group at
>http://groups.google.com/group/kobo-users?hl=en.

Hi!

How do I post it to Google groups? I don’t see an option to add a

file. Should I copy and paste as a text?

You’re using the Google Group online version - but you can also post to the list by email where you’re able to add attachments. Just send an email to kobo-...@googlegroups.com. You can change your membership settings to receive all list updates to your inbox as well so you can read and post to the list by email. Otherwise pasting also works.

Tino

···

On Wed, Oct 26, 2011 at 9:37 AM, Bergie bergi...@gmail.com wrote:

On Oct 24, 12:03 pm, Tino Kreutzer tino.k...@gmail.com wrote:

Hi!

Could you post your original xml survey so we could check it re the time and

date issue?

KoBoSync (formerly known as the post processor) is creating the columns in

the transcribed CSV file pretty randomly, it doesn’t follow the original

order. Part of that is that the XML instances saved by the phone always only

contain the headers of the fields where it contains any data, so if the

first 30 instances didn’t have data for the field ‘current school’ but the

31st does, the ‘current school’ column in the CSV will only be created when

the 31st XML is transcribed. That’s because KoBoSync doesn’t look at the

original questionnaire but only the resulting XML data. You can sort the

columns into a better order in Excel by transposing the whole table first

and sorting the columns, the transposing everything back, or by doing other

tricks in Excel such as hlookups from a separate sheet or file.

Tino

On Sat, Oct 22, 2011 at 5:53 PM, Bergie bergi...@gmail.com wrote:

Good day.

I experience the following problems with KOBO. I did mention it to

Neil Hendrick and he ask me to post here.

With Time selection on phone, in stead of starting at current time ex.

16:30, phone show 4:30 as default. Date is current though.

Upload to aggregate:

The Date only selection, the date is correct, but the time show 00:00

UTC in the cell.

Same for time. Time is correct, but date falls to 01 Jan 1970.

I do want only the date or time respectively on the spreadsheet cell.

How can I change it?

Exporting from Aggregate to CSV, I get what I see, but running it

through Kobo post processor, the heading for the cells and cells, gets

chucked out seemingly randomly.

I am using Open Office Calc, import comma seperated UTF-8.

Any help will be much appreciated.

Regards

You received this message because you are subscribed to the Google Groups

“Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to

kobo-users+...@googlegroups.com.

For more options, visit this group at

http://groups.google.com/group/kobo-users?hl=en.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to kobo-users+...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/kobo-users?hl=en.

See this date below:
<<<<Mon Oct 31 00:00:00 UTC 2011>>>>
It was copied and pasted directly from the resulting spreadsheet. This
is a Date only question type. The time and the UTC bit I don't want in
my output. I am too much of an amateur to make Open Office Calc
recognize it as a valid date.
When I have a Time only question type, the date section goes to 01 Jan
1970.

Thank you

···

On Oct 26, 10:42 am, Tino Kreutzer <tino.k...@gmail.com> wrote:

Hi!

On Wed, Oct 26, 2011 at 9:37 AM, Bergie <bergi...@gmail.com> wrote:
> How do I post it to Google groups? I don't see an option to add a
> file. Should I copy and paste as a text?

You're using the Google Group online version - but you can also post to the
list by email where you're able to add attachments. Just send an email to
kobo-...@googlegroups.com. You can change your membership settings to
receive all list updates to your inbox as well so you can read and post to
the list by email. Otherwise pasting also works.

Tino

> On Oct 24, 12:03 pm, Tino Kreutzer <tino.k...@gmail.com> wrote:
> > Hi!

> > Could you post your original xml survey so we could check it re the time
> and
> > date issue?

> > KoBoSync (formerly known as the post processor) is creating the columns
> in
> > the transcribed CSV file pretty randomly, it doesn't follow the original
> > order. Part of that is that the XML instances saved by the phone always
> only
> > contain the headers of the fields where it contains any data, so if the
> > first 30 instances didn't have data for the field 'current school' but
> the
> > 31st does, the 'current school' column in the CSV will only be created
> when
> > the 31st XML is transcribed. That's because KoBoSync doesn't look at the
> > original questionnaire but only the resulting XML data. You can sort the
> > columns into a better order in Excel by transposing the whole table first
> > and sorting the columns, the transposing everything back, or by doing
> other
> > tricks in Excel such as hlookups from a separate sheet or file.

> > Tino

> > On Sat, Oct 22, 2011 at 5:53 PM, Bergie <bergi...@gmail.com> wrote:
> > > Good day.

> > > I experience the following problems with KOBO. I did mention it to
> > > Neil Hendrick and he ask me to post here.

> > > With Time selection on phone, in stead of starting at current time ex.
> > > 16:30, phone show 4:30 as default. Date is current though.

> > > Upload to aggregate:
> > > >> The Date only selection, the date is correct, but the time show
> 00:00
> > > UTC in the cell.
> > > >> Same for time. Time is correct, but date falls to 01 Jan 1970.
> > > I do want only the date or time respectively on the spreadsheet cell.
> > > How can I change it?

> > > Exporting from Aggregate to CSV, I get what I see, but running it
> > > through Kobo post processor, the heading for the cells and cells, gets
> > > chucked out seemingly randomly.

> > > I am using Open Office Calc, import comma seperated UTF-8.

> > > Any help will be much appreciated.
> > > Regards

> > > --
> > > You received this message because you are subscribed to the Google
> Groups
> > > "Kobo Users" group.
> > > To post to this group, send email to kobo-...@googlegroups.com.
> > > To unsubscribe from this group, send email to
> > > kobo-users+...@googlegroups.com.
> > > For more options, visit this group at
> > >http://groups.google.com/group/kobo-users?hl=en.

> --
> You received this message because you are subscribed to the Google Groups
> "Kobo Users" group.
> To post to this group, send email to kobo-...@googlegroups.com.
> To unsubscribe from this group, send email to
> kobo-users+...@googlegroups.com.
> For more options, visit this group at
>http://groups.google.com/group/kobo-users?hl=en.

Just out of curiosity, is the date and time on your Android correct?

···

On Wed, Nov 2, 2011 at 8:02 AM, Bergie bergi...@gmail.com wrote:

See this date below:

<<<<Mon Oct 31 00:00:00 UTC 2011>>>>

It was copied and pasted directly from the resulting spreadsheet. This

is a Date only question type. The time and the UTC bit I don’t want in

my output. I am too much of an amateur to make Open Office Calc

recognize it as a valid date.

When I have a Time only question type, the date section goes to 01 Jan

Thank you

On Oct 26, 10:42 am, Tino Kreutzer tino.k...@gmail.com wrote:

Hi!

On Wed, Oct 26, 2011 at 9:37 AM, Bergie bergi...@gmail.com wrote:

How do I post it to Google groups? I don’t see an option to add a

file. Should I copy and paste as a text?

You’re using the Google Group online version - but you can also post to the

list by email where you’re able to add attachments. Just send an email to

kobo-...@googlegroups.com. You can change your membership settings to

receive all list updates to your inbox as well so you can read and post to

the list by email. Otherwise pasting also works.

Tino

On Oct 24, 12:03 pm, Tino Kreutzer tino.k...@gmail.com wrote:

Hi!

Could you post your original xml survey so we could check it re the time

and

date issue?

KoBoSync (formerly known as the post processor) is creating the columns

in

the transcribed CSV file pretty randomly, it doesn’t follow the original

order. Part of that is that the XML instances saved by the phone always

only

contain the headers of the fields where it contains any data, so if the

first 30 instances didn’t have data for the field ‘current school’ but

the

31st does, the ‘current school’ column in the CSV will only be created

when

the 31st XML is transcribed. That’s because KoBoSync doesn’t look at the

original questionnaire but only the resulting XML data. You can sort the

columns into a better order in Excel by transposing the whole table first

and sorting the columns, the transposing everything back, or by doing

other

tricks in Excel such as hlookups from a separate sheet or file.

Tino

On Sat, Oct 22, 2011 at 5:53 PM, Bergie bergi...@gmail.com wrote:

Good day.

I experience the following problems with KOBO. I did mention it to

Neil Hendrick and he ask me to post here.

With Time selection on phone, in stead of starting at current time ex.

16:30, phone show 4:30 as default. Date is current though.

Upload to aggregate:

The Date only selection, the date is correct, but the time show

00:00

UTC in the cell.

Same for time. Time is correct, but date falls to 01 Jan 1970.

I do want only the date or time respectively on the spreadsheet cell.

How can I change it?

Exporting from Aggregate to CSV, I get what I see, but running it

through Kobo post processor, the heading for the cells and cells, gets

chucked out seemingly randomly.

I am using Open Office Calc, import comma seperated UTF-8.

Any help will be much appreciated.

Regards

You received this message because you are subscribed to the Google

Groups

“Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to

kobo-users+...@googlegroups.com.

For more options, visit this group at

http://groups.google.com/group/kobo-users?hl=en.

You received this message because you are subscribed to the Google Groups

“Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to

kobo-users+...@googlegroups.com.

For more options, visit this group at

http://groups.google.com/group/kobo-users?hl=en.

You received this message because you are subscribed to the Google Groups “Kobo Users” group.

To post to this group, send email to kobo-...@googlegroups.com.

To unsubscribe from this group, send email to kobo-users+...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/kobo-users?hl=en.

Yes. As I said, date questions have correct date and wrong time, time
questions have correct time but wrong date. Date/time combined
questions have both correct, same for the automatic date/time stamp,
both are correct. Nonetheless I would like to see only the resulting
date or time, not both in the output. Perhaps this is a shortcoming of
XML?

···

On Nov 2, 5:39 pm, Neil Hendrick <neil.h...@kobotoolbox.org> wrote:

Just out of curiosity, is the date and time on your Android correct?

On Wed, Nov 2, 2011 at 8:02 AM, Bergie <bergi...@gmail.com> wrote:
> See this date below:
> <<<<Mon Oct 31 00:00:00 UTC 2011>>>>
> It was copied and pasted directly from the resulting spreadsheet. This
> is a Date only question type. The time and the UTC bit I don't want in
> my output. I am too much of an amateur to make Open Office Calc
> recognize it as a valid date.
> When I have a Time only question type, the date section goes to 01 Jan
> 1970.

> Thank you

> On Oct 26, 10:42 am, Tino Kreutzer <tino.k...@gmail.com> wrote:
> > Hi!

> > On Wed, Oct 26, 2011 at 9:37 AM, Bergie <bergi...@gmail.com> wrote:
> > > How do I post it to Google groups? I don't see an option to add a
> > > file. Should I copy and paste as a text?

> > You're using the Google Group online version - but you can also post to
> the
> > list by email where you're able to add attachments. Just send an email to
> > kobo-...@googlegroups.com. You can change your membership settings to
> > receive all list updates to your inbox as well so you can read and post
> to
> > the list by email. Otherwise pasting also works.

> > Tino

> > > On Oct 24, 12:03 pm, Tino Kreutzer <tino.k...@gmail.com> wrote:
> > > > Hi!

> > > > Could you post your original xml survey so we could check it re the
> time
> > > and
> > > > date issue?

> > > > KoBoSync (formerly known as the post processor) is creating the
> columns
> > > in
> > > > the transcribed CSV file pretty randomly, it doesn't follow the
> original
> > > > order. Part of that is that the XML instances saved by the phone
> always
> > > only
> > > > contain the headers of the fields where it contains any data, so if
> the
> > > > first 30 instances didn't have data for the field 'current school'
> but
> > > the
> > > > 31st does, the 'current school' column in the CSV will only be
> created
> > > when
> > > > the 31st XML is transcribed. That's because KoBoSync doesn't look at
> the
> > > > original questionnaire but only the resulting XML data. You can sort
> the
> > > > columns into a better order in Excel by transposing the whole table
> first
> > > > and sorting the columns, the transposing everything back, or by doing
> > > other
> > > > tricks in Excel such as hlookups from a separate sheet or file.

> > > > Tino

> > > > On Sat, Oct 22, 2011 at 5:53 PM, Bergie <bergi...@gmail.com> > > wrote:
> > > > > Good day.

> > > > > I experience the following problems with KOBO. I did mention it to
> > > > > Neil Hendrick and he ask me to post here.

> > > > > With Time selection on phone, in stead of starting at current time
> ex.
> > > > > 16:30, phone show 4:30 as default. Date is current though.

> > > > > Upload to aggregate:
> > > > > >> The Date only selection, the date is correct, but the time show
> > > 00:00
> > > > > UTC in the cell.
> > > > > >> Same for time. Time is correct, but date falls to 01 Jan 1970.
> > > > > I do want only the date or time respectively on the spreadsheet
> cell.
> > > > > How can I change it?

> > > > > Exporting from Aggregate to CSV, I get what I see, but running it
> > > > > through Kobo post processor, the heading for the cells and cells,
> gets
> > > > > chucked out seemingly randomly.

> > > > > I am using Open Office Calc, import comma seperated UTF-8.

> > > > > Any help will be much appreciated.
> > > > > Regards

> > > > > --
> > > > > You received this message because you are subscribed to the Google
> > > Groups
> > > > > "Kobo Users" group.
> > > > > To post to this group, send email to kobo-...@googlegroups.com.
> > > > > To unsubscribe from this group, send email to
> > > > > kobo-users+...@googlegroups.com.
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/kobo-users?hl=en.

> > > --
> > > You received this message because you are subscribed to the Google
> Groups
> > > "Kobo Users" group.
> > > To post to this group, send email to kobo-...@googlegroups.com.
> > > To unsubscribe from this group, send email to
> > > kobo-users+...@googlegroups.com.
> > > For more options, visit this group at
> > >http://groups.google.com/group/kobo-users?hl=en.

> --
> You received this message because you are subscribed to the Google Groups
> "Kobo Users" group.
> To post to this group, send email to kobo-...@googlegroups.com.
> To unsubscribe from this group, send email to
> kobo-users+...@googlegroups.com.
> For more options, visit this group at
>http://groups.google.com/group/kobo-users?hl=en.