Unable to Deploy Form-No JSON object could be decoded

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.
Ronnie.

I am facing the same issue. Any updates?

···

On Tuesday, March 6, 2018 at 5:51:09 AM UTC+5:30, Ronnie Raraihuru wrote:

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.
Ronnie.

I reproduced this issue using the latest images from github. The kpi image last night (india time, 10 hours ago), did not allow me to create a new project. This was fixed in the image this morning, but I get the same error

Can someone please take a look and fix and/or let us know where to look and debug this issue.

lobo

···

On Tuesday, March 6, 2018 at 10:07:42 PM UTC-8, jamil...@soft-corner.com wrote:

I am facing the same issue. Any updates?

On Tuesday, March 6, 2018 at 5:51:09 AM UTC+5:30, Ronnie Raraihuru wrote:

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.
Ronnie.

Here is a not-so-great workaround for this issue. I will try to look and debug this later today. I got this information from here:

Do the following steps with a broken install:

  1. Edit your docker-compose.yml file. Change kobocat:latest -> kobocat:issue_222

  2. docker-compose pull ; docker-compose up

  3. Deploy the form you built, try to submit a couple of test cases.

  4. Change your docker-compose.yml from kobocat:issue_222 -> kobocat:latest

  5. docker-compose pull ; docker-compose up

things should work now.

Jamila/Ronnie: can you please test and let me know. I’ll do a git diff and figure out what is happening. The core issue is the table koboform_surveydraft is not present in the postgres db

lobo

···

On Thursday, March 8, 2018 at 4:37:02 PM UTC-8, Donald Lobo wrote:

I reproduced this issue using the latest images from github. The kpi image last night (india time, 10 hours ago), did not allow me to create a new project. This was fixed in the image this morning, but I get the same error

Can someone please take a look and fix and/or let us know where to look and debug this issue.

lobo

On Tuesday, March 6, 2018 at 10:07:42 PM UTC-8, jamil...@soft-corner.com wrote:

I am facing the same issue. Any updates?

On Tuesday, March 6, 2018 at 5:51:09 AM UTC+5:30, Ronnie Raraihuru wrote:

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.
Ronnie.

Thank you Lobo – just confirming our team will be on this ASAP. We are sorry for the inconvenience.

P.

···

Here is a not-so-great workaround for this issue. I will try to look and debug this later today. I got this information from here:

https://github.com/kobotoolbox/kobo-docker/issues/162

Do the following steps with a broken install:

  1. Edit your docker-compose.yml file. Change kobocat:latest -> kobocat:issue_222

  2. docker-compose pull ; docker-compose up

  3. Deploy the form you built, try to submit a couple of test cases.

  4. Change your docker-compose.yml from kobocat:issue_222 -> kobocat:latest

  5. docker-compose pull ; docker-compose up

things should work now.

Jamila/Ronnie: can you please test and let me know. I’ll do a git diff and figure out what is happening. The core issue is the table koboform_surveydraft is not present in the postgres db

lobo

On Thursday, March 8, 2018 at 4:37:02 PM UTC-8, Donald Lobo wrote:

I reproduced this issue using the latest images from github. The kpi image last night (india time, 10 hours ago), did not allow me to create a new project. This was fixed in the image this morning, but I get the same error

Can someone please take a look and fix and/or let us know where to look and debug this issue.

lobo

On Tuesday, March 6, 2018 at 10:07:42 PM UTC-8,
jamil...@soft-corner.com wrote:

I am facing the same issue. Any updates?

On Tuesday, March 6, 2018 at 5:51:09 AM UTC+5:30, Ronnie Raraihuru wrote:

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.

Ronnie.

You received this message because you are subscribed to the Google Groups “KoBoToolbox Users” group.

To unsubscribe from this group and stop receiving emails from it, send an email to kobo-users+unsu...@googlegroups.com.

To post to this group, send email to
kobo-...@googlegroups.com.

Visit this group at
https://groups.google.com/group/kobo-users
.

For more options, visit
https://groups.google.com/d/optout
.

Thanks Lobo,

I have tested that and i think it is working.

Thanks.

Ronnie

···

On Friday, March 9, 2018 at 12:33:39 PM UTC+11, Donald Lobo wrote:

Here is a not-so-great workaround for this issue. I will try to look and debug this later today. I got this information from here:

https://github.com/kobotoolbox/kobo-docker/issues/162

Do the following steps with a broken install:

  1. Edit your docker-compose.yml file. Change kobocat:latest -> kobocat:issue_222
  1. docker-compose pull ; docker-compose up
  1. Deploy the form you built, try to submit a couple of test cases.
  1. Change your docker-compose.yml from kobocat:issue_222 -> kobocat:latest
  1. docker-compose pull ; docker-compose up

things should work now.

Jamila/Ronnie: can you please test and let me know. I’ll do a git diff and figure out what is happening. The core issue is the table koboform_surveydraft is not present in the postgres db

lobo

On Thursday, March 8, 2018 at 4:37:02 PM UTC-8, Donald Lobo wrote:

I reproduced this issue using the latest images from github. The kpi image last night (india time, 10 hours ago), did not allow me to create a new project. This was fixed in the image this morning, but I get the same error

Can someone please take a look and fix and/or let us know where to look and debug this issue.

lobo

On Tuesday, March 6, 2018 at 10:07:42 PM UTC-8, jamil...@soft-corner.com wrote:

I am facing the same issue. Any updates?

On Tuesday, March 6, 2018 at 5:51:09 AM UTC+5:30, Ronnie Raraihuru wrote:

I have tried to deploy a sample form in KoboToolbox(on my own server ) and i am receiving this error message-See attachment.

Did anyone having this same error managed to solve this?.

Please advice.

Regards.
Ronnie.