Unable to edit a submission made by Tella

I have the same error.

I tried:

  • Different browsers (Chrome, Firefox)
  • Tried incognito
  • Clearing browser cache
  • Submitting a new record (I use Tella App) and tried editing the new record
    My efforts didn’t resolve the problem, I am still getting:
Data server did not accept data.
Contact survey administrator please. (400)

What else can I try?

Welcome to the community, @Philippe! Did you get this error when you tried to submit an edited submission? Kindly please also let us know the server you are using. This should help us troubleshoot your issue.

Hi Kal_Lam, thanks for the reply.

I get this error on every record, old and new (unedited). I submitted a new test record through the Tella app, and tried editing it when it arrived…same error.

We use the humanitarian server.

Thanks for the support.

@Philippe, would you mind trying out KoboCollect android app instead of Tella to see if the submissions collected by KoboCollect android app too have submission errors? Please let us know what happens.

Hi Kal_Lam,

Thank you for your suggestion. I tried the KoboCollect app and was able to edit the record after submitting it. So the problem lies in the way the Tella app submits records? How can I start to debug this? Thanks for your help so far!

1 Like

@Kal_Lam One more thing I tried:

I built a new form from scratch using the KoboToolBox browser form builder.
I added a single text question “name” and left everything default, with no changes in settings.

Saved → Deployed → Downloaded form to Tella App → Filled out form → Succesful submission → tried editing the record in KoboToolBox → Received same error (400)

I did this test to see if any questions, settings, or form configurations could cause this. But with a new form and a single text question and everything at default it produced the same error.

1 Like

Hi @Philippe, can you please send me a private message with the following details so I can investigate:

  • server (Kobo/OHCA)
  • username
  • project

@Philippe, you should now be able to send PMs. If you still have issues please refresh your page.

1 Like

Hi @Philippe, it looks like the issue is in the meta/instanceID field created by the Tella app. I duplicated the submission you had in the test project (which creates a new instanceID value) and was able to edit it successfully. You can see the difference here in the submissions’ XML, with the one from Tella above and the duplicated one below:

            id="aMYptRC8A2jUDesCwuEQ3F" version="1 (2022-06-24 07:42:12)">
        <aMYptRC8A2jUDesCwuEQ3F id="aMYptRC8A2jUDesCwuEQ3F"
            version="1 (2022-06-24 07:42:12)">
  • Tella: <instanceID>XNELRNMPD9O2BXSPBEUORMOGC</instanceID>
  • Kobo: <instanceID>uuid:7185c01c-cdd4-434d-b454-c737fcb72bf4</instanceID>

I would suggest rather using Collect/KoboCollect for your data collection as they have been through far more user testing than a new app.

1 Like

Thanks for pinpointing the problem @Josh !
I will send this to Tella.

I wish I could use Collect or KoboCollect for my current project, but the Tella app has several security features aimed at data collectors in high-risk environments which we are currently working in.

Thanks again!