Unable to update an existing form


I’m not able to update an existing form.

When I try to replace the form, it keeps on saying “Import Name: Failed…”. It suggeste this could be a network issue but it’s not.

Then I tried to update the form using the build option, I still got an error (see attached). Can someone please help me out.

Welcome to the community, @Ayowumie! Have you tried that on a PC to see how it behaves? In addition, please also try validating your XLSForm through this online validator to see if there are any syntax issues.

Thank you @Kal_Lam for your quick response. The form is validated and there is no syntax error.

When I tried on PC, here is the error message:

Import Failed!
Name: $community_summary_matrix.xlsx
DeploymentDataException: Cannot alter _deployment_data directly

How do I fix this please?

@Ayowumie, maybe try sharing your XLSForm with the community. The community should also be able to help you out.

I believe this is a problem that has to do with Kobo. Same form was deployed on ONA and it worked.

It is a Kobo Server issue. Someone once made a similar complaint in the community in 2021 (See link - Error: Import Failed! - User Support / Form Building - KoboToolbox Community Forum). It was fixed by Kobo from the backend.

I think this is a problem specific to Kobo (and not the form) because this error appear even if i take a survey previously deployed and download and upload without any change and the errors repeat.

The problem started 10.11.2023. The same above error is produced with all my forms.
@Josh @Kal_Lam

1 Like