Uploading edits to a record not submitting (error)

When this issue happens, could you please:

  1. Open a new tab;
  2. Log out of Enketo using one of these links, depending on the server you use:
  3. Go back to the previous tab and attempt to submit your edit again.

If this does not fix the problem, please provide reproduction steps that are as detailed as possible. Does this happen for all forms? All Kobo accounts that you use? All browsers, devices, etc.?

Please also open your browser’s developer tools (if using a desktop browser), select the “Network” tab, and try to submit again while this is open. Then, take a screenshot of the developer tools and attach that here as well.

1 Like

Welcome to the community, @new_ger_project! Have you tried following this method as discussed previously?

It should help you solve your issue.

When I am trying to edit any collected information then most of the time its show error.

@new_ger_project, did you follow the instructions outlined in the previous post to see if that solved your issue?

Yes, and nothing has changed :confused:

@new_ger_project, could you provide me the following through a private message?

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

Hi - i just tried the fix (logging out … logging in again - going to the data section - edit the record - open record in enketo - edit what i wanted and then submit - with the same error…
Submission service on data server not found. (404)
I tried using chrome and edge and the problem was in both browsers.
Not sure if i followed the instructions exactly - but tried to.
Let me know if there is anything else to do. I’m sure i was able to edit no problem before… i am in the toolbox.org server and it is the same problem on multiple projects.

Attaching a screenshot with the developer tools window opened… hope it shows what you want to see… the second one had another window open up when i hovered on the red text in the developer window. I have no idea what anything means!

Has anyone successfully solved this yet?
It is kind of a pain if we can’t edit our data.
Thanks for working on this!

1 Like

Hi @tabas, thank you very much for the response.

I opened the submission in your screenshot and was able to edit it successfully (I wrote !!! TEST BY KOBO SUPPORT !!! in the Driver Other field, which was previously empty). This confirms my suspicion that this problem is somehow related to authentication information stored in the browser.

If you have time, could you please also try the following?

  1. Make sure all Chrome incognito windows are closed (or close the entire Chrome browser to be sure);
  2. Open a new incognito window;
  3. Log in directly to the Kobo account you are using to attempt these edits—
    • Do not log into any other Kobo accounts or visit any other Enketo forms;
  4. Attempt the edit again.

If that doesn’t work, we’ll need to begin a private message to inspect your browser’s cookies. Do not post any information about cookies in this public topic, because they could contain sensitive information about your account.

For others reading, I would encourage you also to try using “incognito” or “private browsing” features of your browser to see if this makes a difference. However, I would also like to emphasize that logging out of Enketo, using the URLs I posted earlier, is not the same thing as logging out of your KoboToolbox account the usual way. Again, those URLs are:

Thanks for helping us troubleshoot this issue.


Bingo!! that did it. Thnaks so much.
Previously, I didn’t understand the importance of logging out using your link that you provided. This time I logged out with your link. But my other pages that were open were still there… i further logged out in those … then re - logged in like normal.
Seems i can now edit like before.
So it is really important to use your log out link when we encounter this problem.
Much appreciated your help!

1 Like

Great, thanks for the confirmation. We’re working on a fix so that logging out of Enketo using those links won’t be necessary in the near future.

1 Like

Hello @jnm

Kindly note that I am currently facing the same problem. The challenge is that I have multiple users working on editing the records, and the Log out option did not work with some of them.

Is there an update for this error.

Thank you in advance.


I still have the same problem, eventhough I tried all the above solutions and nothing worked.
I really need to solve this out ASAP, I hope you help me with it.

Thanks dear, please note that I am still facing this issue. I hope that KoBo support team can advice on this.

This error is making a lot of challenges in our work.

@dwaimah, is this seen in the project where you tried to link your project dynamically?

Thanks @Kal_Lam

No, the project is not linked dynamically.

@Ahmad, did you also try this out in a different browser?

Yes @Kal_Lam . please note that we have faced this with different browsers and users.

@Ahmad, could you provide me the following through a private message? Maybe I could have a closer look at your case.

  • Username
  • Project name
  • Server

You should be able to send me a private message as outlined in the post discussed previously:

@Ahmad, is this an issue for all the records, or does it only have issues for specific _id's?

It happens with me in all records, no matter what id
even when Im using another device, another browser