Uploading edits to a record not submitting (error)

Thank you so much @Josh and Kobo team.

Regards,

2 Likes

Thank you so much @Josh and Kobo team.

On behalf of the entire FAO Colombia team, thank you very much

Regards,

2 Likes

@ccamilocr, @Ahmad can you confirm that the issue has been resolved on your end with the latest deployment?

1 Like

Thanks @Josh, please note that I have tried editing submissions and it works well with me. I have spent around 20 minutes on some submissions and it works well.

Furthermore, please note that I have noticed the following two points:
Point #1: The “DATA” tab does not refresh the data automatically after editing a submission, and if you tried to edit the same submission that was edited previously without refreshing the data, the submission will be opened but at the end, you will receive an error. I would suggest preventing the edit from the beginning.

Point #2: I am not sure if this is related, but I have noticed that the “Hyperlinks” did not work well after this new update, I have some links in my form and it used to work well previously, but now the link is being opened by having the following sentences before the actual link:
In new submission: https://ee.humanitarianresponse.info/x/%20
In edit submission: https://ee.humanitarianresponse.info/edit/%20

Thank you so much.

1 Like

Hi @Ahmad, thank you for the feedback! Your first point is a valid suggestion and we will improving the editing process in the future. For your second point, I don’t seem to be able to reproduce the issue on my end. Can you please share the following with me in a private message so I can take a look:

  • username
  • project name
2 Likes

Hi @Ahmad, it looks like the issue is not related to the update but rather Enketo not stripping leading white space from markdown links in the label.

If I create a label with two links, one without a leading space and one with:

Link [without a space](https://google.com), link [with a space]( https://google.com)

Everything looks normal in the form itself:

Screenshot 2022-06-29 at 12.30.34

… but if you inspect the links:

  • [without a space](https://google.com)https://google.com
  • [with a space]( https://google.com)enketo-kobo-server-address https://google.com

The HTML shows the leading space value of %20:

<span class="question-label active" lang="">
  <p>Link 
    <a href="https://google.com/" rel="noopener" target="_blank">without a space</a>
    , link 
    <a href="%20https://google.com" rel="noopener" target="_blank">with a space</a>
  </p>
</span>

I’ll create a GitHub issue on the Enketo side for this :+1:

2 Likes

Thank you for all the support @Josh . I will check my form and adjust the spaces.

Overall, I am really thankful for the Kobo support team. The edit submission indeed helps us in our tracking and updating of the data, I do appreciate your support.

Regards,

2 Likes