URGENT (probably severe bug): files on Settings/Media now ignored!

Our form uses search and pulldata, accessing an external csv file (with geographic and other details for facility selection). I now deleted the csv file and replaced it with a new one (after editing a few data) – but the form kept showing the old (wrong) entries.

Then I deleted the csv file form Settings/Media (which should lead to a file not found error message), but the form (deleted and uploaded afresh on KoboCollect) kept on working (however with the old data).

I noticed that the look and feel of the Settings/Data page has changed and assume that something has gone wrong in the context of these changes.

Can you please very urgently check?

Hi @york_rff
We have had other users reporting the same issue. We are currently looking into this to determine if there is to determine the rootcause. We should be able to respond to users as soon as we resolve this.


1 Like

@york_rff, we have a similar issue reported here:

Sorry for not finding this (I had tried).

Is there a special bug report channel?

However, I would expect that external csv files are used a lot and that that many organizations are now in trouble. Is there a “news” board or something like that where you post such urgent and severe issues and keep us updated re mitigation?

@york_rff, will get back to you soon with a GitHub issue for this. However, please be informed that this has already been discussed in our team.

Hi all,

Glad this issue has been reported and discussed, as it is affecting us too.

I have a different but possibly related case that might add more data to your debugging: We have a form that uses a select_multiple_from_file question. After replacing this file today, we can no longer download the form to ODK Collect / KoboCollect.

The Collect apps always fails to download if it cannot find the file referenced by the select_multiple_from_file question. We have confirmed the file is in the same format as before, so the only thing I can think of is that Collect cannot find this file we have uploaded.

I also notice that downloading a file from the Settings > Media page always gives me a “download.csv” file - regardless of the original’s name. If the Collect app is also getting a file without the original name, it would explain both the error I’ve described and the one described by @york_rff.

Thanks to the Kobo team for looking into this so quickly, and hopefully it’s a quick fix! Please let me know if you need any more information about our issues to help the debugging.

1 Like

Hi @degami
They are both related as it involves updating the cvs files onto KoBoCollect which does not seem to be happening as needed.


1 Like

Any news regarding the impossibility of maintaining the external csv files?

@york_rff, @degami please be informed that you could solve your issue temporarily as outlined in the post discussed previously:

1 Like

Thanks a lot for the hint of the workaround (basically: redeploy form each time a settings/media csv-file is uploaded). It didn’t work several times and I tried all kinds of variations: only redeploy, upload new form with still the same (but not effective) csv file), delete csv-file and only then only redeploy or deploy freshly uploaded form, etc. Not sure what exactly worked finally and whether this is a stable workaround.

So, I really hope that the feature will be fully functional again soon…

1 Like