Error: Expecting value: line 2 column 1 (char 1)

Hi all,

I’m having issues deploying a form and keep getting the error: Expecting value: line 2 column 1 (char 1). I’ve tried to followed other similar threads but it doesn’t seem that the options are relevant to my form. I’ve also run the form through the ODK verifier here, but no issues are coming up. Does anyone know why this might be? It’s a very simple form so it should be pretty straightforward!

aKfprJ2L5xbskgJdN7zjvJ.xlsx (13.5 KB)

Hi @zradanovic
This always points out an issue with your form. Kindly go through the following discussion and contextualize it to your form


1 Like

Hi Stephane,

I’ve run the form through the ODK validator and nothing appears. I’ve tried to see if it is the language but perhaps I am missing something. I continue to receive the same error.
aKfprJ2L5xbskgJdN7zjvJ.xlsx (13.5 KB)

Have you searched through previous articles where we have discussed this issue?


Hi there!

Yes, I have tried as I mentioned in my original post. The “note” question is not referencing itself, but the issue is at the level of the note question type because when I remove it, the form deploys without issue.

Hi @zradanovic, it looks like the issue is that your calculation (${SOH} div ${AMC}) for the calculate question is under relevant rather than calculation. When I changed this the form deployed without issue :+1:

1 Like

Hi Josh,

I have tried to change the column to be calculation, but I still get the same error using the attached form and I still get no errors on the ODK validator.
a2hhY8mLDRUnoKye7LFyZi.xlsx (13.4 KB)

Hi @zradanovic, when I use that form I can deploy without error… can you try re-uploading that form and see if it works?

1 Like

@zradanovic, there are some names which is not supported properly. FYI:

Maybe you will need to replace RFHP-EN with RFHP_EN or simply provide a unique number starting from 1 and increasing gradually.

Note: you will also have to change the use of / to _ or use a unique number as advised above. Similarly, use of , or space is also not allowed.

Fix this and this should solve your issue.

1 Like

Hi Kal,

It is still giving me the same error.
Screenshot 2021-07-28 090053

I’ve tried to start new projects, I followed all the guidance and the ODK validator is showing me no errors. The form I am using is the one attached. To make sure it is not an error in the “name” column, I changed all the choice names to unique numbers as you suggested. Is this something with my KoboToolbox account? @Josh is saying it works but every iteration I try is unsuccessful.
a2hhY8mLDRUnoKye7LFyZi (1).xlsx (13.5 KB)

Hi all.

My form is still not deploying and I noticed in other threads that it could be because of the server being used. Can you kindly help?

Thank you

@zradanovic, I could upload your xlsform to my humanitarian server without any issue. I didn’t see any error message. I was also able to make a submission to the server with the same.