Error extracting data from Kobotoolbox

Hello. A while ago, I started a new project and began collecting data. Yesterday, I had the intention on the server to modify some data in the collected dataset, instead I received an error message.

I also repeatedly tried to export the collected data with the intention to modify some of the data offline, however that failed:

I suspect this failure might have to do with the error that I received earlier. I also noted that I cannot edit the used form for collecting the data. The error message asks me to contact you. Can you help me to solve this issue?

So did you do the following which resulted in the export error:

  • Made changes to your survey form
  • Redeployed your survey project
  • Then the data download failed

Yes, I saw that I redeployed my survey 4 times (see picture).

I don’t know how to see what the original versions have been deployed. How can you find that?

Thanks for the assistance!

Do you have a repeat question in this survey project?

No, I have not.

Thanks for your assistance!

Would you mind sharing with us the following through a private message? Maybe we could have a closer look at it.

  • Username
  • Project name
  • Server

[quote=“Webex, post:3, topic:17936”]
don’t know how to see what the original versions have been deployed. How can you find that?

  • The very first version should be your original version
  • Clone that into a new project, and you can safely download the XLS version of the form.


Continuing the discussion from Error extracting data from Kobotoolbox:
Dear Kal_Lam

Thanks for your swift response!

Unfortunately, I receive this message when I am trying to send a private message:

“Sorry, you cannot send a personal message to that user.”

I think that has to do with restricted possibilities as new user on this forum.

@Webex, you should now be able to. If you still have issues sending a private message, please refresh your page.

@Webex, when looking to your survey project closely I could observe that you accidentally made a typo error in A18 with select_one ProfileCode.csv:

Image 1

I fixed the same to select_one_from_file ProfileCode.csv:

Image 2

Note: When you have a select_one_from_file question type you will need to download your data as XLS (legacy) as the normal download would not support for the same:

Thanks a lot for the solution! However, it is strange that despite the error, the survey worked during the data collection…

Thanks a lot also for the feedback for the select_one_from_file question type and how to download it. Regarding this: I see that the XLS (legacy) will not be supported in the future. How can you download the collected data if use you select_one_from_file feature again in the future?

Once again, thanks in advance!

1 Like

@Webex, we will let you know when we have an upgrade for this feature.

@Kal_Lam, will the XLS (legacy) stay supported until the feature is upgraded? We have several surveys coming up in the future where select_one_from_file feature is needed, otherwise is de form very slow in loading (a lot of tables).

1 Like

Yes, it will be there until we upgrade!

Thanks for the information. I have one last question before I close this issue: I made a clone of the “Form Samples with CSV” named "Clone Form Samples with CSV’ to get the original form. I tried to remove it, but I received this error:


Can you explain me what I am doing wrong?

Thanks for the patience with me!

So you mean you wish to delete Clone Form Samples with CSV? Shall i have a look at it and try deleting them at my end?

Yes, I wish to delete Clone Form Samples with CSV. I just tried again and now I can check all the boxes and delete the form instead getting an error. Very strange, but it is solved!

Thanks for your reply!

1 Like

Thank you for confirming, @Webex!