Error in date seen in View utility

Dear community.

I’m having an error while viewing a stored date through the VIEW utility. The date displayed is always one day before the actual date registered in that submission. In the screenshot I show the date as displayed in the VIEW feature (the one with the error - red ) Vs. the dates in the EDIT feature, the table view and the Excel file downloaded (yellow).

This is the only submission with this issue and has never ever happened to me before. I’d really appreciate any insights on the subject.



Welcome to the community, @sergiousmeglsdominic! Would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server
  • _id

Note: You could share with me a private message as outlined in the post discussed previously:

@sergiousmeglsdominic, it’s OK when I view the same _id at my end. FYR…

Great. Could that mean that it has something to do with some specific settings in my account?

Untitled_ Sep 15, 2023 7_37 AM

I also tried doing it from a different account and different device: same results:

WhatsApp Video 2023-09-15 at 7.58.00 AM

Some updates.

  1. Same thing is happening in other projects in the same account in all submissions (not as I wrote before, with only one submission)
  2. I created a new project with a date field using a different account. Same results.
  3. I tried using a different device. Same thing.
  4. Tried using a different browser


Would you mind to check the correctness of the date/time and timezone configuration on the used device (and your network), please?

Hi @wroos , thank you for your reply.

Yes, I did with two different devices, accounts and networks, all properly configurated. Also, I found that I’m not the first one experiencing this issue: