Error occured when trying to modify existing data with answers from csv

When i’m trying to modify existing submissions from admin console, i see error message: “Start tag expected, ‘<’ not found”.
I checked the form with online validator and it says that everything is OK. After research i found that problem in field that gets answers from csv file. I tryed to leave only one simple value in this csv file, but no luck. I can edit form only when it gets answers from internal source.

@hitower2000, could you kindly share a screenshot of our issue, please? Could you also let the community know the server you are using?

I’m using server

@hitower2000, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

I have shared additional info in private message as requested above.
And i found out that now when i uploading csv file and rederploying form i can’t download it back from media page. Earclier i could do this any time, but now only before form will be redeployed, after this it show file in list but occur error message “file unavaliable on site” when i’m trying to download it.

1 Like

@hitower2000, try following the steps outlined below, which should help you solve this issue (as discussed in our previous post):

  • Delete the CSV file from the project/server.
  • Upload the CSV file back to the project.
  • Deploy/redeploy

If this still does not work, please feel free to contact us. We will investigate your issue again.

Yes, this solution solving problem with updating csv files and access to them for new surveys, but i still can’t edit old answers with same error message.

@hitower2000, as a quick check, would you mind cloning the project and then making a dummy submission? Submit the dummy submission and then try editing that submission to see if you are able to make edits to that particular submission?

I’ve already tried this. I even tried to create a new form with just one question and connect the answers from the csv. But as a result in both cases, when editing, I still got the same error

@hitower2000, is this an issue for a single submission or all submissions?

@Kal_Lam all submissions in all forms

@hitower2000, did you try cloning a project and then have some dummy submissions to that project? Maybe try making edits to the dummy submissions to see how it behaves?

@Kal_Lam Yes, i tried cloning project. As i said before i also tried to create absolutely NEW form with only one question that takes answers from csv file and made one dummy submission. As result i cant edit it either.

@hitower2000, have you tried this workaround?

If that, too, does not work, could you try removing this choice_filter as shown in the image below:


Yes, i tried this workaround and its working for updating answers in csv files for NEW submissions, but not for editing old ones. As for your suggestion about removing choise_filter - its impossible, becouse i don’t have any filters in my simplest test form

@hitower2000, maybe try downloading your project in XLSForm and then check out all the columns. You will see the same under the survey sheet.

I just sent you screenshot from downloaded XLSForm in previous message and you can see all my columns :slight_smile:
Is it just me who has this problem? Сan everyone else edit old submissions?

@hitower2000, could you share your project name with me again? It seems like I checked it out for the wrong project.

Just sent in private message. First time i gave you link copy of existing project, now we are talking about simple test project to simplify research. Thanks!

1 Like

@hitower2000, if this is your CSV file, you must fix it with a proper identifier.