Forms shared between accounts not appearing on mobile devices

Dear all, hope you’re having a wonderful day and happy new decade!

Description: Forms shared between different accounts (lets call them A, B, and C) are not showing up on mobile devices.

Steps to Reproduce

On https://kobo.humanitarianresponse.info

  1. Account A creates Form “1”. Settings are normal: Offline and online submissions. Form is deployed normally. => Form “1” can be seen on Account A “deployed” forms in projects on KOBO humanitarian response webpage. Form “1” can also be seen on any mobile device where the “KOBO” Application is connected to the server https://humanitarianresponse.info/A as well as https://humanitarianresponse.info and username A, password xxxxxx.
  2. Form “1” Is then shared with account B. Sharing privilages “submit form” OR “submit form and view submissions” (both cases, no difference in outcome)

Expected behavior

i. Account B can view form (and view submissions if allowed) on webpage of https://kobo.humanitarianresponse.info
ii. Account B can also access through “get form” the form on their mobile devices either through URL: Https://kc.humanitarianresponse.info/B OR Https://kc.humanitarianresponse.info/ and Username: B, Password xxxxx

Actual behavior

“i” works normally. Account B can view form (and view submissions if allowed) on account kobo webpage aforementioned. I did not try but it seems that I can also submit forms.

“ii.” does not work. When “Get form” is selected on a mobile device only the forms uploaded to the account natively would appear and can be downloaded. All shared froms cannot be.

Additional details

  • Did i try the full url (…/B)? Yes
  • Did i try the generic URL (https://kc.humanitarianresponse.info) with Username and password? Yes
  • Did I try the full URL with username and password? Yes
  • This applies to forms shared last week and all other forms shared all the way back to March 2019
  • This applies to forms shared by account “C” to “B” and from “A” to “C” as well i.e. Not exclusive to two specific accounts.
  • Did I make sure that the same or older versions of the forms were not already on the phone? Yes. The phones did not have the same or older versions of the forms, they still did not appear on “get form”
  • A test form uploaded today was also tested. Same result.
  • This was tried on 5 different phones - All android, all samsung, different makes.
  • KOBO Application versions tested: v1.23.3k and v1.14.0a as well as others.

What should topics in this category generally contain?

Dont know

Do we need this category? Can we merge with another category, or subcategory?

Dont know

Thank you very much,
Your friendly Neighborhood MEAL Manager

Hi @MEAL_Manager_DEZ,

Welcome back to the community! Would you mind providing me the following in a private message so that i could have a look at my end (being Account B):

  1. User Name
  2. Your Email ID
  3. Project Name (that has issues on sharing)

Have a great day!

Hi @MEAL_Manager_DEZ,

I had a quick look over to your issue and was able to get the survey to my KoBoCollect android app (by sharing it to my KoBoToolbox user account). I kept the exact settings that you have made while sharing it i.e. used the permission as shown in the image below:
image

Reference that i was able to Get Blank Form to my device:

Please ensure you have the correct configuration settings under the Server Settings:

URL: https://kc.humanitarianresponse.info

Username: xxxxx

Password: xxxxx

Note: do not use the / key at the end of the URL. It this still does not work try resetting the sharing permissions. It should work by now.

Have a great day!

It seems to have worked. Not sure how it wasnt the first time, thank you!

1 Like

Hello Kal!

Thank you for your rapid response on the issue above! It is interesting because in fact I had tested all the different variables of access (URL/Username/Password) with no success, is there any chance there was a temporary bug? Then again I could have also messed up somewhere!

Thank you!

Best,
Anwar

1 Like

Hi,
I highly suspect that there was no bug. However given that this is working, let us monitor the behavior and see. It could have also been just a potential connectivity issue but we may never really know

Stephane

1 Like