Hyperlink to photo attachment no longer working

I am not sure if I missed a change or what, but was wondering if I need to change how I am downloading attached photos.

I can no longer view photo attachments using the instructions in

I can only use this on old photos (> 1 month):

New photos only works if I include the Form ID and the UUID:


Any explanation or insight is greatly appreciated.

Before yesterday i could only download old pictures by using hyperlink (> week), but now the hyperlink is not working for old & the new photos.

Any help regarding this issue is highly appreciated


I just tried it on my end and I was able to see a photo with this URL (replacing the userID and the file name): https://kc.humanitarianresponse.info/attachment/original?media_file=[username]/attachments/[filename]

Maybe your default browser is not signed in to the correct KoBo account?

I checked my browser is signed into the correct KoBo account.

I can see most files, not just the new ones. The last one I can view without the formid/uuid is Nov 2, 2018. The next form photo was uploaded on Nov 21, 2018 and I cannot see that one.

If I edit the URL in the browser, and add the formID and UUID, I can see then see the file in the browser.

Today I can see all my old photos in all my forms working fine by the hyperlink, but any record registered from 21 Nov 2018 & above are not appearing by the hyperlink but you can see them in the gallery, I have tried this with many forms but with the same problem.

Our engineers need to have a look. Could you send me a personal message with an exported spreadsheet that includes the URL for all attachments, and mark the ones that don’t work (highlight them in red)? Please reference this thread!

Thank you !

I will get permission from the client and get back to you.

Thanks again.

Hi there,

This issue seems to be connected to a recent update to KoBoCAT (https://github.com/kobotoolbox/kobocat/pull/496). We have marked it as a high priority bug (https://github.com/kobotoolbox/kobocat/issues/500) and hope to have it resolved as soon as possible.


I have verified that new images can be downloaded using the instructions on the support page (without the formID and UUID).

I still have to access the images that were affected by this with the workaround : including the FormID and UUID. There are not that many and we can still use this workaround for these files.



This bug report has been closed and the issue should be resolved. Please post here if you are still not able to use the hyperlink to view recent photo attachments.

Team Kobo

Hi ,

is there still an issue with the hyperlinks to view collected images (unhcr server) ? Besides i can not download the photos in batch. (8gb). All the photo are accesible throught the table under data section in KOBO.


I just collected new photos with surveys.
I’m using OCHA server and the hyperlink solutions is not working and downloading the zip file is too big and our connexion too poor to use it.
Do you have any other solutions?
Many thanks