I cant acess settings account

I can’t access
to account settings, when I click, nothing happens

@martinhocatumbela, which browser are you using? Could you change your browser to a modern one like the Chrome, Edge, Firefox to see how it behaves?

Neither one works, I tried using Edge and Chrome but the result is the same, apart from the fact that I can’t share a project if I’m in the “Form” tab, only if I’m in the “Summary” tab I can share, In other words, in the form tab I almost can’t do much, even to download the XLS I have to right-click on the download option and open it in a new tab, I don’t know why this happens but I don’t think it’s the problem of browsers or the operating system, I use Windows 11 and the browsers have been constantly updated.

@martinhocatumbela, could you also let us know the server you are using?

Global KoboToolbox Server

@martinhocatumbela, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

@martinhocatumbela, I don’t have issues accessing your ACCOUNT SETTINGS.

I tried checking through Chrome and had no issues. If you are using some other browsers try using modern browsers such as Chrome, Edge or Firefox. And that should solve your issue.