I have the same loading issue

@Kal_Lam Hello,

I have the same issue, I have this error message :
error message

I have already uploaded this file to another form and it worked perfectly…

Thanks in advance.

Welcome to the community, @Raphael! Did you mean you were able to resolve the issue?

No, I mean that the same file used to work perfectly but this issue appeared just today, I’ve never had this issue with the same file.

@Raphael, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:


Ive sent you a private message, but I still have the same issue…
Could you help me ?



I’ve had the same issue since yesterday. For the same csv file, sometimes it works, but sometimes it doesn’t while I don’t change in the file. Could you help to resolve this ?


@Raphael, we will need to check out your CSV file. Could you kindly share it with the community please?

Thnaks for your help, pleind find attached the .csv file
Comm_deleg_Kobo.csv (1.5 MB)

@Raphael, maybe I will also be needing your XLSForm for the testing. Could you kindly share it with the community please?

@Raphael, try following the steps outlined below, which should help you solve this issue (as discussed in our previous post):

  • Delete the CSV file from the project/server.
  • Upload the CSV file back to the project.
  • Deploy/redeploy

If this still does not work, please feel free to contact us. We will investigate your issue again.

@Kal_Lam Thanks for your response but I’ve already tried tu delete/upload but it still doesn’t work. I think there is an issue with the media uploading tab because I can upload my cvs file and redeploy ma form but in the media tab if I want to download the csv file I uploaded earlier, it doesn’t work and in the download tab of my browser, it is said “impossible to dowload the file”.

1 Like

@Kal_Lam In fact, I think there’s a problem with Kobo’s media tab. I can normally load a document in csv format, I can also deploy the form but as soon as I open it, I get an error message: “impossible to load document XXX.csv” whereas this same document works perfectly on another form so I guess the problem isn’t with the .csv document itself. What’s more, once I’ve loaded my csv document on Kobo’s media tab, if I want to download it again, the following error message appears in my browser’s download tab: “file not available on the site”.
Could you help me solve this quickly?
Thanks in advance.

1 Like

@Raphael , you are right. CSV file uploading seems to be malfunctioning now, and the same problem has happened to me when downloading the survey.

For you to be able to make a survey operational, you need to perform now a new step which, in my opinion, should not be necessary.

This is now how I am, after this issue started, dealing with csvs:

  1. Delete CSVs (the broken/unwanted ones)
  2. Redeploy survey without any CSVs
  3. Upload new CSVs
  4. Redeploy survey again
  5. Result → CSVs and Survey operational (if I now skip step 2, I get problems with the survey and when downloading it says “File wasn’t available on site”.)

Before, the process could just be done without step 2 which is what makes sense.

@Raphael , can you confirm this too? Please give it a test.



@luisrodx Thank you very much for your help.
Yes, it seems to work on my side too, although I must admit it’s not very practical. I hope this will be resolved soon.

1 Like

Hi @luisrodx and @Raphael,
I’ve had the same problem today and I’ve followed the steps recommended by @luisrodx and that works.

Thanks for your posts !

1 Like

You are welcome @Raphael and @zurbaran!

@Kal_Lam , can you please take a look on this? It seems that what I identified is indeed the source of the problem.

Thank you!

1 Like

Thank you for sharing the workaround @luisrodx! Will make a quick test to see if it’s still breaking at my end.

Hi @Kal_Lam , any update?


@luisrodx, we are trying to check this out on a project that has an issue (not working currently).

Hi @Kal_Lam , it seems that you already confirmed that this is “how the system now behaves” in this other post https://community.kobotoolbox.org/t/media-files-needs-to-be-uploaded-all-the-time/52173, so I guess this is to remain, right?

Can you also mark my answer as the solution for this post, as the one you presented is outdated?

Thank you!

1 Like