Literacy Widget Word at Flash

Dear Community,

I’m using the literacy widget with the 60 second body::kb:flash, word at flash. I’ve used this widget in the past and after 60 seconds the screen flashes yellow and you can select the last word read at 60 seconds with a check box below the word. This is used to calculate words correct per minute (a very useful literacy measure). At 60 seconds, boxes should appear under each word to allow data entrants to select the last word read, however the boxes are not appearing unless words are marked as incorrect. If a respondent was able to read all the words correctly, we won’t be able to mark the last word read at 60 seconds.

This is strange for a number of reasons. First, I went back to old forms where this worked correctly and it is no longer showing the check boxes under words at the 60 second mark if the rest of the words are correct. I cross checked with colleagues, who duplicated the error. I also tried in Google Chrome and Microsoft Edge and the error persisted.

Any advice is appreciated! I can share the full form if that helps.

Best,
Ally Krupar

HI @allykrupar5
Welcome to the community forum, Could you please share an XLS version of the form that had previously worked and any associated media so that we can try it on our end.

Stephane

I’ve uploaded two files, one is the HALDO assessment for a project and the other is the literacy widget (not developed by me) since the project includes both right to left and left to right script. Both files have the same issue.

HALDO Kobo WLR_Arabic 2020.xls (72.5 KB) Copy of RTL literacy widget demonstration.xls (39.5 KB)

Hi @allykrupar5
You had indicated that this had worked before. Could you please send the xlsform that belongs that particular one that had worked before?

I also noticed some few things that you could clarify.

  1. You are using namespaces on the settings, however I am not seeing how you are referencing that on the namesheet. Is there something missing within your widget?
  2. Have you ever tried this in a left to right language without inserts of right to left language?

Stephane

Hi Stephane,

Thanks for the response. The forms I added above have worked before, also the enclosed form has worked before. HALDO_Kobo_Nigeria_11-9.xlsx (36.3 KB)

  1. I’m honestly not sure how to use namespaces in the namesheet. Can you send guidance on this? This is something included on all of the forms I’ve used in the past, and I assumed it was a reference for Enketo.
  2. The literacy widget has worked on left to right and right to left previously.

Best,
Ally

Hi @allykrupar5,

I made a small change in your language from english to english (en) and it seems to work:

It should now work with both English as well as arabic language.

Reference xlsform:

HALDO Kobo WLR_Arabic 2020.xls (72 KB)

1 Like

Thanks! But unfortunately, that did not correct the error at 60 seconds. The problem isn’t that the literacy passage does not appear in Arabic and English, it does. The problem is that at the 60 second flash (body::kb:flash), there should be check boxes under the words so the data entrant can identify the last word read. Those boxes were appearing in previous uses, but are missing now. If you run the form and let it go until 60 seconds, the screen flashes yellow, but only one check box appears, under the last word of the passage. They should appear under each word.

1 Like

Hi @allykrupar5,

This seems to be a bug! Kindly please be informed that i have created a GitHub issue which you should be able to follow it here:

1 Like

Hi @allykrupar5,

I’d just like to confirm what you’re seeing. If zero words are marked as incorrect by the flash time, then only the final word in the passage receives a check box:

However, if at least one word has been marked incorrect, then the check boxes appear as they should:

The code that controls this is in Enketo, and we last updated Enketo on August 18:

Do you think it’s possible that the problem first appeared back in August, or was the literacy widget working properly more recently than that? Knowing whether a change in our code or some other change (e.g. a new version of a browser) caused the problem will be helpful for troubleshooting.

Thanks

1 Like

Hi @jnm

We used the tool in September and it was working then. I’m not sure when the problem first appeared unfortunately, but I posted about it as soon as I noticed it (after testing internally).

Thank you!
Best,
Ally

OK, we will get it fixed ASAP.

1 Like

Hi @allykrupar5, this should now be fixed by the latest release of Enketo:

2 Likes