Form list download failed when trying to get blank forms in KoBoCollect android app

Hello - I am having the same problem. I am positive my humanitarianresponse URL is correctly entered as are my username and password. The custom server path section is as default - nothing has been changed there. The device is successfully connected to the internet and the auto date/time are on for the device and correct. I am at a loss! Can someone please help? Thank you.

Welcome to the community, @Eellis! Could you share with the community the screenshot of the error message you are having?

Hi Cal - please see image here. If it’s faster for us to speak directly I am happy to do so. This is presenting a huge challenge for our data collection at the moment.


As mentioned, all of the standard trouble shooting we have explored (wrong URL, wrong username/password, date/time not right on device, no internet connectivity etc). We have the tablets distributed to our team country wide and every person is getting the same error on their tablets. When I log out of our username/password and log into a different account with then the problem goes away - I can ‘get blank forms’. The second I log back into our account, the error appears. Thanks.

As a quick check would you mind downloading your xlsform and then validate them with this online validator? It should help you identify syntax errors if any present.

Hi Kal - yes we know that site and always check our forms. Just to be extra sure, I deleted all forms that we were testing and have only left the live forms in use with data (which are already downloaded onto everyone’s tablet). This unfortunately did not solve the problem. Do you perhaps have a way for us to chat directly so that we can hopefully resolve this issue today? Thank you.

Is this an issue in only a particular device or are you facing the same issue with other devices too?

All devices as explained above. Kal, I’d really appreciate if there was someone I could speak to directly to resolve this issue please?

I have just tried to create another account so we can continue with Kobo. However, when I try to do this via the website, I get a 505 Server Error - could this be connected? Could this be a server issue and not an issue to us specifically?

As a quick check would you mind downloading your project as an xlsform and then upload the same as a new project to see if you are able to get the newly deployed project in your KoBoCollect android app?

Hi Kal all of our projects are generated in excel and then uploaded / deployed. I just uploaded a form that we have successfully uploaded / deployed previously and this seems to have done the trick! Now when I click get blank form I can see this form + all of our live data forms. Can you please explain what likely caused this issue in the first place so we don’t face it again? Thank you!

@Eellis, there could be two possible reasons for this:

  1. Configurations of the Collect android app not done correctly
  2. If the xlsform has some syntax errors that are not supported by the Collect android app

Don’t know which one should be affecting your case. Maybe we could have a closer look at it if you share the following with us through a private message:

  • Username
  • Project name
  • Server

Hi Kal - how do I message you privately? I am sure that #1 was not the issue; I logged in / logged out and retyped the url, username, password about 100 times. I then checked all settings against a humanitarianresponse account that was working and they were the same. If it’s a syntax issue, normally Kobo gives us that error and blocks that particular form from being deployed vs. blocks us from accessing our forms as a whole?

You should be able to send a private message as outlined in the post discussed previously:

I see a number of projects in your user account. Can you please list me the project name that is not loading in your Collect android app?

@Eellis, I could download all the survey projects in my KoBoCollect android app:

If you are still having issues, kindly please recheck your configurations as outlined in our support article:

Hi Kal - yes the issue was resolved when I deleted all test forms and then re-uploaded one of them. I want to understand why the issue happened in the first place. Nothing was loading; when we went to ‘get forms’ it gave us the error that I shared earlier

If one of the forms was the cause of the trouble, one of the ones I deleted, then I won’t know which one. What I don’t understand is if it was a problem with syntax, then why would the form have been deployed in the first place? Normally if there is a challenge then it gives us the error when we try to deploy and won’t deploy.

@Eellis, don’t know what exactly happed at your end. As everything worked well at mine. Maybe we could find out the real reason on why it happened the next time (if the same happens).