Not able to view my media after adding new media to the SETTINGS>Media

hi, i have some question, i upload media .csv
but after new version upload media in kobotoolbox the pull data in form i build didn’t read the csv file.

can someone explain the solution ?


Welcome to the community, @fakhrizalakbar1! Could you kindly carry out the following steps to solve the issue:

  • Create a new project from scratch/upload an xlsform as a new project
  • Upload media under SETTINGS>Media
  • Deploy if it’s a new project/redeploy if it’s an existing project

So this is the step moving forward because KoBoToolbox is now able to preview a form with media files before going live. So each time you add a media file, you should redeploy which is different then what it used to be previously (where you did not have to redeploy after adding a media file).

For details, please see the discussion that has happened in this post:

i try upload media and deploy its success, but with redeploy not success

yea that’s right, because sometimes we need to update media. and i try redeploy its doesn’t work

@fakhrizalakbar1, will have a look at it and get back to you.

i’m looking forward to its, thanks

@fakhrizalakbar1, I tested and it’s OK for me at my end. Could you share the SETTINGS>Media for your project? This should give us a clue to see if the media has been synced from KC to KPI and are there.

i re-upload databcsdanbch but when i redeploy, and get blank form in android application its didn’t downloaded the data

@fakhrizalakbar1, would you mind sharing with me the following information through a private message so that I could have a closer look at it?

  • Username
  • Project name
  • Server

done i sent to you

1 Like

@fakhrizalakbar1, I see 2 projects with the same name. Which is the project you are trying to refer?

its same project, because i couldn’t re-deploy so i made another one, you can choose either one of them.

@fakhrizalakbar1, when looking at your xlsform I see the following issues:

In row 6 under the calculation column you have used pulldata('databcsdanbch','Position(Jobtitle Approval)','EmployeeID',${EmployeeID}) where Position(Jobtitle Approval) is not allowed as it contains (, ) and even spaces. Fix them and it should work. While fixing, please also ensure that the same is fixed at the header of the CSV file databcsdanbch. This should solve your issue.

but, before this version that form don’t have any problem

@fakhrizalakbar1, the upgrade has now enabled users to upload CSV file directly through the KPI without the need of the KC.

can you give me exemple how i query this ?

Sorry, could you kindly simplify this?

i try redeploy form after upload csv, it’s not success. but when i upload csv and edit some field in form than save and redeploy its success.

1 Like

@fakhrizalakbar1, the temporary workaround for this is the following workflow:

When you are designing a new project:

  • Design survey project (from form builder or upload an xlsform)
  • Upload CSV file/media file
  • Deploy

In cases where you simply wish to update your CSV file from an ongoing survey project:

  • Delete the CSV file that is present in the server from SETTINGS>Media
  • Update your CSV file and then upload the same back to the server
  • Go to FORM>Edit
  • Make no changes but simply press the SAVE button
  • Redeploy