Failure to access csv file uploaded to Settings/Media

The long established procedure to upload a csv file to Sharing/Media and access its data though the “appearance” expression “minimal search” suddenly fails.

The path shown in the error message (storage/emulated/0/Android/data/ Partners MDC Tool v1 8 2 ZW_7-media) doesn’t have any similarity with the path where the csv file is stored ( – is that a hint on why it is not working any more? Should it really be “koboc” with a “c” in the end of

All our field workers in 4 countries are currently blocked to do their work – please get back urgently.

@york_rff, could you see if the CSV file format is okey?

Very urgent issue, because all our field workers in four of six countries are blocked!

The long established procedure to upload a csv file to Settings/Media and make the form access its data by the “appearance” expression “minimal search” is suddenly failing.

Not sure whether it is a hint on the issue, but the path of where the csv file is stored ( has no similarity to the path shown in the error message (file missing): storage/emulated/0/Android/data/ Partners MDC Tool v 8 2 ZW_7-media).

And is it really “koboc” with a “c” at the end in “”?


@york_rff, do you get this error message in your Collect Android App?

Yes! This is what happens.

@york_rff, which app are you using? The KoboCollect Android App or the ODK Collect Android App? Besides, it is also an issue with Enketo?

KoboCollect Android App

1 Like

We don’t use Enketo…

If this is Enketo: Yes, the issue occurs there, too.

@york_rff, could you kindly share with me your CSV file so that I could have a look to see if it’s an issue (formatting issue that is not supported by the system) with the same?

The error message is clearly saying “file missing” – but here it is:
facilities_ls.csv (126.7 KB)

However, maybe you want to check the following first: We are using two external files, namely apart from that csv file a png file with logos. I have now uploaded that png file afresh and – exactly the same error message now occurs in the form:
File missing!

Very, very likely that your colleagues have changed something on the path definition this morning. EDIT: Sorry, not this morning, but yesterday around lunchtime.

@york_rff, would you mind trying the following steps please to see if that helps?

  • Delete the media files from your project.
  • Deploy your project.
  • Upload the media files.
  • Deploy your project.

Kindly please let us know what happens.

@Kal_Lam, you and your team are great – it worked!

Thanks so much!!!

1 Like

@york_rff, :clap: :heart: :partying_face:

@Kal_Lam, it looks like the solution works, but from now on needs to be applied EACH TIME (not just a fix of a temporary hick-up)!?

Is this a known bug, the team is working on?

@york_rff, we have not identified it yet. We are still investigating. Will let you know if it’s a bug.

Hi @Kal_Lam any word on what the underlying problem is? Seems quite a few community members are hitting this problem! Hope it gets a swift resolution - thanks for your work


@nat, we will update it through the community when we find anything for it.

1 Like

xref Github ticket tracking this fix: Replacing an attached file in the Media does not work as expected · Issue #4914 · kobotoolbox/kpi · GitHub

1 Like

@york_rff, @nat, kindly please be informed that the bug has been fixed. FYR …

1 Like